summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-22 21:27:16 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-22 21:39:58 +0200
commite3119d844121f6c9079dccead9874a23df2dc7c2 (patch)
tree55b55031bfb76885802b775e7b2d383f5bb40051
parentgames-arcade/mrrescue: Drop old (diff)
downloadgentoo-e3119d844121f6c9079dccead9874a23df2dc7c2.tar.gz
gentoo-e3119d844121f6c9079dccead9874a23df2dc7c2.tar.bz2
gentoo-e3119d844121f6c9079dccead9874a23df2dc7c2.zip
games-action/trosh: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-action/trosh/trosh-20-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-action/trosh/trosh-20-r1.ebuild b/games-action/trosh/trosh-20-r1.ebuild
new file mode 100644
index 000000000000..5de7abfdbbc1
--- /dev/null
+++ b/games-action/trosh/trosh-20-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils gnome2-utils
+
+DESCRIPTION="A game made in 20 hours for a friend. It has explosions"
+HOMEPAGE="http://stabyourself.net/trosh/"
+SRC_URI="http://stabyourself.net/dl.php?file=trosh/trosh-linux.zip -> ${P}.zip
+ https://dev.gentoo.org/~hasufell/distfiles/${PN}.png"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=games-engines/love-0.8.0:0
+ media-libs/devil[png]
+"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_install() {
+ local dir=/usr/share/love/${PN}
+
+ exeinto "${dir}"
+ doexe ${PN}.love
+
+ einstalldocs
+
+ doicon -s 32 "${DISTDIR}"/${PN}.png
+ make_wrapper ${PN} "love ${PN}.love" "${dir}"
+ make_desktop_entry ${PN}
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}