summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-11-01 21:01:11 +1300
committerKent Fredric <kentnl@gentoo.org>2017-11-01 21:01:30 +1300
commite328456dc1bff7445e192aa63e47df7bd92b58d6 (patch)
tree0618acce56579876ccba73cb420cea5b97144ecd
parentdev-perl/MailTools: Bump to version 2.190.0 (diff)
downloadgentoo-e328456dc1bff7445e192aa63e47df7bd92b58d6.tar.gz
gentoo-e328456dc1bff7445e192aa63e47df7bd92b58d6.tar.bz2
gentoo-e328456dc1bff7445e192aa63e47df7bd92b58d6.zip
dev-perl/Math-BigInt-Lite: Bump to version 0.170.0
Upstream: - Improve blog() with regards to objectify() - Fix bexp() from objectifying too many args - Add from_bin, from_oct, from_hex - Correct bdiv to do floored division - Add btdiv Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--dev-perl/Math-BigInt-Lite/Manifest1
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild33
-rw-r--r--dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch34
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Manifest b/dev-perl/Math-BigInt-Lite/Manifest
index b2522f33c1f9..65d43fd98d19 100644
--- a/dev-perl/Math-BigInt-Lite/Manifest
+++ b/dev-perl/Math-BigInt-Lite/Manifest
@@ -1 +1,2 @@
DIST Math-BigInt-Lite-0.14.tar.gz 44517 SHA256 0ae0d1fdfbfe0d1801f3fd99d1958a61958f1d50ce4d38acca735e85ef3035ef SHA512 abee57d6497566f8dfa32d273f0ef9cf914ed57b9397c61455695cbfc141fce8f1ccd2c65a2043ec0d4843dc0a1cde978a0b8b05bcc12e71a7438cd379a462c5 WHIRLPOOL a64b379303cf26d048975087082aec768fbac1e46d9bcf03a6d43de0206f2fb2e649fe041628ea2fb90eae14f23d5778c246fb53c01ebd491f26e8362038c307
+DIST Math-BigInt-Lite-0.17.tar.gz 71248 SHA256 f3323f5537dda709a9718ee1a730394651c085eddab665a84a4adee9991931de SHA512 8a1eb42d43a09cc7e16a9c430c6fb1a9c2f799e1dd3cb67436a6fafff510ed39550d4db8d28f5992c754c8391e0e9700b230e9b74dd05a108faecc9f0e55ef4e WHIRLPOOL b9e091c7954b654301ffba5956d78ad80360c853c1c049cf637e10b0536e52611265ca229bb9984aec4c2dd7f368390352ae4640888fe8f672250e7157ba037f
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
new file mode 100644
index 000000000000..037b684079f9
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.170.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=0.17
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.801
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+ test? (
+ >=virtual/perl-Test-Simple-0.520.0
+ virtual/perl-Math-BigRat
+ )
+"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ # https://rt.cpan.org/Public/Bug/Display.html?id=75667"
+ #bad_files+=( "t/bigintpm.t" )
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}
diff --git a/dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch b/dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch
new file mode 100644
index 000000000000..d8ae23982ae7
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/files/Math-BigInt-Lite-0.170.0-no-dot-inc.patch
@@ -0,0 +1,34 @@
+From 5cb03904937102876d331e04cd36f3520fc5a5f6 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 1 Nov 2017 20:50:35 +1300
+Subject: Fix tests without '.' in @INC
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=120893
+---
+ t/bigintpm.t | 2 +-
+ t/mbi_ali.t | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/t/bigintpm.t b/t/bigintpm.t
+index 49efbad..a714bd0 100644
+--- a/t/bigintpm.t
++++ b/t/bigintpm.t
+@@ -14,4 +14,4 @@ $CALC = "Math::BigInt::Calc";
+ #############################################################################
+ # all the other tests
+
+-require 't/bigintpm.inc'; # all tests here for sharing
++require './t/bigintpm.inc'; # all tests here for sharing
+diff --git a/t/mbi_ali.t b/t/mbi_ali.t
+index cacf83e..b2da6f9 100644
+--- a/t/mbi_ali.t
++++ b/t/mbi_ali.t
+@@ -12,4 +12,4 @@ use Math::BigInt::Lite;
+ our $CLASS;
+ $CLASS = 'Math::BigInt::Lite';
+
+-require 't/alias.inc';
++require './t/alias.inc';
+--
+2.14.3
+