summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-06-28 18:22:41 -0400
committerMike Gilbert <floppym@gentoo.org>2017-06-28 18:22:59 -0400
commite33a8389b6fe9d54a3dc5c831a1438137e5a5df7 (patch)
treeec801cfe82b4dadf5e3ca20226730cbcadcecbe7
parentsys-apps/systemd: amd64 stable (diff)
downloadgentoo-e33a8389b6fe9d54a3dc5c831a1438137e5a5df7.tar.gz
gentoo-e33a8389b6fe9d54a3dc5c831a1438137e5a5df7.tar.bz2
gentoo-e33a8389b6fe9d54a3dc5c831a1438137e5a5df7.zip
dev-util/pkgconf: bump to 1.3.7
Package-Manager: Portage-2.3.6_p9, Repoman-2.3.2_p77
-rw-r--r--dev-util/pkgconf/Manifest1
-rw-r--r--dev-util/pkgconf/pkgconf-1.3.7.ebuild72
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild2
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index e83351b7913e..30eed7d4df42 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -5,3 +5,4 @@ DIST pkgconf-1.0.2.tar.xz 247972 SHA256 a7c67f8603c0d0400be17b2efac0fdc9ff46625f
DIST pkgconf-1.1.0.tar.xz 264428 SHA256 5f1ef65d73a880fa5e7012102a17f7b32010e5e46139aed85851a541ba828a63 SHA512 2d54b14b9fb830a3d30e8812f6079a95cf1e1e77fd42d1eac7a6041347094ff88b79146be93c56625c44e2dcf38af725cbbdfdda09b457b921a9a17b97a23d15 WHIRLPOOL deffe0277f48f39b3824a25f255da6cdf51bdcf973d9b19f8eb166ba388c6440451d07bf37862f044a4e8be572d4ea5406ff243759fa5f22c0e6ecce8064ba31
DIST pkgconf-1.2.2.tar.xz 267268 SHA256 b445d16df8b6e88489039eb2d7d91d5668025cb058a1852f3e0fdee19c8cb104 SHA512 0d9f74a69bd36f55b1485341127bff08487d5216ae495cea0474e6d23bb323d5c8c7d36b25c2e58282b1bcb0d74da6bb93ee0757e98405aba42b13f2e76eeac2 WHIRLPOOL ef2fe3045b058d627a920e3f2648bbfe2de763bb3f52f61b835684b533cbd768fd0ef892d7c99b89ac73b42d02ba4409d098b285d2943cad6017617112087257
DIST pkgconf-1.3.5.tar.xz 271216 SHA256 886c397b22907209a7483229a8bf473afe151de50527c4b4d04b94fdba0f0c8e SHA512 a937607a5a868f136b1f8018f152512a3c6997e1e73baf7bd9af54c3e5542ecdac2f24df0078df2e0c8544060ba26a25ade88b7949c97ca4fe783d656a1804de WHIRLPOOL 9287c800063cac6ff8124a131e9f99c89112f56f9e14f72f525d97f3041a7444b4b71a64779925f5352a80f7205ae66e30e30ce98a5926dcd9c6ce1c1bb9519f
+DIST pkgconf-1.3.7.tar.xz 271840 SHA256 1be7e40900c7467893c65f810211b1e68da3f8d5e70fddb883fc24839cad0339 SHA512 6c06afc4fe64c94a833db98d4dc7881192d38cc28eb1fb86345f4ce065489930ac953aa9f6b2df172127244cb1cbab1c85a042aa0f6be4fa18bf9dcd83173960 WHIRLPOOL eaf41a5ff5c7521ae365197a89745d74dca39a4e91e27631fa54d5b641e941943dd8edc4e1d258db4fd0aa562e9db1253782ad423a2e7edbb5e09394c1abc108
diff --git a/dev-util/pkgconf/pkgconf-1.3.7.ebuild b/dev-util/pkgconf/pkgconf-1.3.7.ebuild
new file mode 100644
index 000000000000..75020aac5d88
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-1.3.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
+ inherit autotools git-r3
+else
+ SRC_URI="https://distfiles.dereferenced.org/pkgconf/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~x86"
+fi
+
+inherit ltprune multilib-minimal
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config test"
+
+# tests require 'kyua'
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ dev-libs/atf
+ dev-util/kyua
+ )
+"
+RDEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ default
+
+ [[ ${PV} == "9999" ]] && eautoreconf
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf
+}
+
+multilib_src_install() {
+ default
+
+ if use pkg-config; then
+ dosym pkgconf /usr/bin/pkg-config
+ else
+ rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
+ fi
+}
+
+multilib_src_install_all() {
+ prune_libtool_files
+ einstalldocs
+}
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 38899a433dfd..75020aac5d88 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -8,7 +8,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit autotools git-r3
else
SRC_URI="https://distfiles.dereferenced.org/pkgconf/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~x86"
fi
inherit ltprune multilib-minimal