summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-05-14 11:00:04 +0200
committerMichał Górny <mgorny@gentoo.org>2016-05-14 11:06:49 +0200
commite34fc4f42494d880d1948fe9ebfb0c4d15c0e068 (patch)
tree1ca32632d04bb3231e4c6423483e55b7d287587a
parentwww-servers/nginx: fix upstream check module segfault for bug 582992 (diff)
downloadgentoo-e34fc4f42494d880d1948fe9ebfb0c4d15c0e068.tar.gz
gentoo-e34fc4f42494d880d1948fe9ebfb0c4d15c0e068.tar.bz2
gentoo-e34fc4f42494d880d1948fe9ebfb0c4d15c0e068.zip
dev-python/pypy: Fix pax-marking in src_compile()
-rw-r--r--dev-python/pypy/pypy-4.0.1.ebuild4
-rw-r--r--dev-python/pypy/pypy-5.0.0.ebuild4
-rw-r--r--dev-python/pypy/pypy-9999.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/pypy/pypy-4.0.1.ebuild b/dev-python/pypy/pypy-4.0.1.ebuild
index 9a64dcbae0d0..2fed250c8ace 100644
--- a/dev-python/pypy/pypy-4.0.1.ebuild
+++ b/dev-python/pypy/pypy-4.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -165,7 +165,7 @@ src_compile() {
"${@}" || die "compile error"
use doc && emake -C pypy/doc/ html
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
+ pax-mark m pypy-c libpypy-c.so
}
src_test() {
diff --git a/dev-python/pypy/pypy-5.0.0.ebuild b/dev-python/pypy/pypy-5.0.0.ebuild
index 9a64dcbae0d0..2fed250c8ace 100644
--- a/dev-python/pypy/pypy-5.0.0.ebuild
+++ b/dev-python/pypy/pypy-5.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -165,7 +165,7 @@ src_compile() {
"${@}" || die "compile error"
use doc && emake -C pypy/doc/ html
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
+ pax-mark m pypy-c libpypy-c.so
}
src_test() {
diff --git a/dev-python/pypy/pypy-9999.ebuild b/dev-python/pypy/pypy-9999.ebuild
index 331ea557e59e..52a085171b1f 100644
--- a/dev-python/pypy/pypy-9999.ebuild
+++ b/dev-python/pypy/pypy-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -171,7 +171,7 @@ src_compile() {
"${@}" || die "compile error"
use doc && emake -C pypy/doc/ html
- pax-mark m "${ED%/}${INSDESTTREE}/pypy-c"
+ pax-mark m pypy-c libpypy-c.so
}
src_test() {