summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2023-08-16 10:45:15 -0400
committerRichard Freeman <rich0@gentoo.org>2023-08-16 10:45:15 -0400
commite35d715ebd098067176566bd065ee65340b5ed6a (patch)
treeddfcfec0e3d6b7248dbadf4d50ab9c02db614188
parentsys-process/systemd-cron: revbump since installed files change (diff)
downloadgentoo-e35d715ebd098067176566bd065ee65340b5ed6a.tar.gz
gentoo-e35d715ebd098067176566bd065ee65340b5ed6a.tar.bz2
gentoo-e35d715ebd098067176566bd065ee65340b5ed6a.zip
sys-process/systemd-cron: use split-usr USE flag to detect split usr
This approach is the same as used by sys-apps/systemd-9999. Signed-off-by: Richard Freeman <rich0@gentoo.org>
-rw-r--r--sys-process/systemd-cron/systemd-cron-1.16.7-r1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/sys-process/systemd-cron/systemd-cron-1.16.7-r1.ebuild b/sys-process/systemd-cron/systemd-cron-1.16.7-r1.ebuild
index e44362e5d6bf..c94d705a9f69 100644
--- a/sys-process/systemd-cron/systemd-cron-1.16.7-r1.ebuild
+++ b/sys-process/systemd-cron/systemd-cron-1.16.7-r1.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid test yearly"
+IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid split-usr test yearly"
RESTRICT="!test? ( test )"
RDEPEND=">=sys-apps/systemd-217
@@ -29,9 +29,15 @@ DEPEND="sys-process/cronbase
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-src_prepare() {
- [[ -L /bin ]] || die "systemd-cron requires a merged /usr"
+pkg_pretend() {
+ if use split-usr; then
+ eerror "Please complete the migration to merged-usr."
+ eerror "https://wiki.gentoo.org/wiki/Merge-usr"
+ die "systemd no longer supports split-usr"
+ fi
+}
+src_prepare() {
python_fix_shebang --force "${S}/src/bin"
sed -i \