summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-02-10 09:20:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-02-10 10:10:58 +0100
commite369c2c53ce31624c7d741664e33d4557baf5d12 (patch)
tree124bbe684cd6ce7bfb7fbe561cb1049598f1bff4
parentkde-frameworks/kinit: drop 5.88.0* (diff)
downloadgentoo-e369c2c53ce31624c7d741664e33d4557baf5d12.tar.gz
gentoo-e369c2c53ce31624c7d741664e33d4557baf5d12.tar.bz2
gentoo-e369c2c53ce31624c7d741664e33d4557baf5d12.zip
kde-frameworks/kio: drop 5.88.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kio/Manifest1
-rw-r--r--kde-frameworks/kio/files/kio-5.88.0-fix-KRun-open-URLs-twice.patch87
-rw-r--r--kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch28
-rw-r--r--kde-frameworks/kio/kio-5.88.0-r2.ebuild99
4 files changed, 0 insertions, 215 deletions
diff --git a/kde-frameworks/kio/Manifest b/kde-frameworks/kio/Manifest
index 6595f5bde265..a34f2e8dd917 100644
--- a/kde-frameworks/kio/Manifest
+++ b/kde-frameworks/kio/Manifest
@@ -1,2 +1 @@
-DIST kio-5.88.0.tar.xz 3247924 BLAKE2B 3687e97b3c936c93e7ee87f314340f8e9889e2afae584d360eb44414994406a34678ea304fff081a65beb03fa98ec1f22870f3a3f86e124352bc96f51c142c1f SHA512 3d79bc90c2f6aa54080824c15da282f54d18530362ffd144f36754f1751f58c0c48c9fd12ffece49f0b455c524b8585ba6c2baa684b0992471b7ec0636350c19
DIST kio-5.90.0.tar.xz 3264964 BLAKE2B d6925472295eacce1f08458f5d184edec7828475d8561d574180a043421c453f46daeb10b76636b9246aaa630a0f50f71f5379c36520b607bd23f75be237c002 SHA512 944d12155beb424e9359ae93dea8db2847658eafbde595c54dc193bcddaca61000be9f2141ee31c535b126eeef5a4d8ae09b079896b5a807c3d72fbea98d66b3
diff --git a/kde-frameworks/kio/files/kio-5.88.0-fix-KRun-open-URLs-twice.patch b/kde-frameworks/kio/files/kio-5.88.0-fix-KRun-open-URLs-twice.patch
deleted file mode 100644
index 0d3bf2aeca3a..000000000000
--- a/kde-frameworks/kio/files/kio-5.88.0-fix-KRun-open-URLs-twice.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-From 25f3a6937a80f2748790265b9b688d64126e43d0 Mon Sep 17 00:00:00 2001
-From: Aleix Pol <aleixpol@kde.org>
-Date: Tue, 30 Nov 2021 17:33:18 +0100
-Subject: [PATCH] Fix KRun::runApplication when xdg activation is involved
-
-Has waitForStarted account for xdg activation token request.
-
-BUG: 446272
----
- src/gui/kprocessrunner.cpp | 13 ++++++++++---
- src/gui/kprocessrunner_p.h | 1 +
- 2 files changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/src/gui/kprocessrunner.cpp b/src/gui/kprocessrunner.cpp
-index 130dade75..82c959afe 100644
---- a/src/gui/kprocessrunner.cpp
-+++ b/src/gui/kprocessrunner.cpp
-@@ -32,6 +32,7 @@
- #include <QProcess>
- #include <QStandardPaths>
- #include <QString>
-+#include <QTimer>
- #include <QUuid>
-
- #ifdef Q_OS_WIN
-@@ -259,7 +260,6 @@ void KProcessRunner::init(const KService::Ptr &service,
- Q_UNUSED(iconName);
- #endif
-
-- bool waitingForXdgToken = false;
- if (KWindowSystem::isPlatformWayland()) {
- if (!asn.isEmpty()) {
- m_process->setEnv(QStringLiteral("XDG_ACTIVATION_TOKEN"), QString::fromUtf8(asn));
-@@ -274,7 +274,7 @@ void KProcessRunner::init(const KService::Ptr &service,
- }
- if (window) {
- const int launchedSerial = KWindowSystem::lastInputSerial(window);
-- waitingForXdgToken = true;
-+ m_waitingForXdgToken = true;
- connect(this, &KProcessRunner::xdgActivationTokenArrived, m_process.get(), [this] {
- startProcess();
- });
-@@ -285,6 +285,7 @@ void KProcessRunner::init(const KService::Ptr &service,
- if (tokenSerial == launchedSerial) {
- m_process->setEnv(QStringLiteral("XDG_ACTIVATION_TOKEN"), token);
- Q_EMIT xdgActivationTokenArrived();
-+ m_waitingForXdgToken = false;
- }
- });
- KWindowSystem::requestXdgActivationToken(window, launchedSerial, QFileInfo(m_serviceEntryPath).completeBaseName());
-@@ -316,7 +317,7 @@ void KProcessRunner::init(const KService::Ptr &service,
- m_description = userVisibleName;
- }
-
-- if (!waitingForXdgToken) {
-+ if (!m_waitingForXdgToken) {
- startProcess();
- }
- }
-@@ -331,6 +332,12 @@ void ForkingProcessRunner::startProcess()
-
- bool ForkingProcessRunner::waitForStarted(int timeout)
- {
-+ if (m_process->state() == QProcess::NotRunning && m_waitingForXdgToken) {
-+ QEventLoop loop;
-+ QObject::connect(m_process.get(), &QProcess::stateChanged, &loop, &QEventLoop::quit);
-+ QTimer::singleShot(timeout, &loop, &QEventLoop::quit);
-+ loop.exec();
-+ }
- return m_process->waitForStarted(timeout);
- }
-
-diff --git a/src/gui/kprocessrunner_p.h b/src/gui/kprocessrunner_p.h
-index 1f94df7a2..df6f08f64 100644
---- a/src/gui/kprocessrunner_p.h
-+++ b/src/gui/kprocessrunner_p.h
-@@ -140,6 +140,7 @@ protected:
- qint64 m_pid = 0;
- KService::Ptr m_service;
- QString m_serviceEntryPath;
-+ bool m_waitingForXdgToken = false;
-
- private:
- void emitDelayedError(const QString &errorMsg);
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch b/kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch
deleted file mode 100644
index a6a4877cf0f4..000000000000
--- a/kde-frameworks/kio/files/kio-5.88.0-fix-copy-between-filesystems.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From aef544ebbb11e842209f3b071eaa9d1c2f26fa40 Mon Sep 17 00:00:00 2001
-From: Albert Astals Cid <aacid@kde.org>
-Date: Wed, 17 Nov 2021 23:45:17 +0100
-Subject: [PATCH] Fix copying between different filesystems on Linux < 5.3
-
-From the copy_file_range manpage
-
-EXDEV The files referred to by fd_in and fd_out are not on the same mounted filesystem (pre Linux 5.3).
----
- src/ioslaves/file/file_unix.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/ioslaves/file/file_unix.cpp b/src/ioslaves/file/file_unix.cpp
-index b4eca2ae9..02b5dc14c 100644
---- a/src/ioslaves/file/file_unix.cpp
-+++ b/src/ioslaves/file/file_unix.cpp
-@@ -813,7 +813,7 @@ void FileProtocol::copy(const QUrl &srcUrl, const QUrl &destUrl, int _mode, JobF
- const ssize_t copiedBytes = ::copy_file_range(srcFile.handle(), nullptr, destFile.handle(), nullptr, s_maxIPCSize, 0);
-
- if (copiedBytes == -1) {
-- if (errno == EINVAL) {
-+ if (errno == EINVAL || errno == EXDEV) {
- break; // will continue with next copy mechanism
- }
-
---
-GitLab
-
diff --git a/kde-frameworks/kio/kio-5.88.0-r2.ebuild b/kde-frameworks/kio/kio-5.88.0-r2.ebuild
deleted file mode 100644
index d262628dccb5..000000000000
--- a/kde-frameworks/kio/kio-5.88.0-r2.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_DESIGNERPLUGIN="true"
-ECM_TEST="forceoptional"
-PVCUT=$(ver_cut 1-2)
-QTMIN=5.15.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org xdg-utils
-
-DESCRIPTION="Framework providing transparent file and data management"
-
-LICENSE="LGPL-2+"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-IUSE="acl +handbook kerberos +kwallet X"
-
-# tests hang
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/libxml2
- dev-libs/libxslt
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtdeclarative-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- =kde-frameworks/kauth-${PVCUT}*:5
- =kde-frameworks/karchive-${PVCUT}*:5
- =kde-frameworks/kbookmarks-${PVCUT}*:5
- =kde-frameworks/kcodecs-${PVCUT}*:5
- =kde-frameworks/kcompletion-${PVCUT}*:5
- =kde-frameworks/kconfig-${PVCUT}*:5
- =kde-frameworks/kconfigwidgets-${PVCUT}*:5
- =kde-frameworks/kcoreaddons-${PVCUT}*:5
- =kde-frameworks/kcrash-${PVCUT}*:5
- =kde-frameworks/kdbusaddons-${PVCUT}*:5
- =kde-frameworks/kguiaddons-${PVCUT}*:5
- =kde-frameworks/ki18n-${PVCUT}*:5
- =kde-frameworks/kiconthemes-${PVCUT}*:5
- =kde-frameworks/kitemviews-${PVCUT}*:5
- =kde-frameworks/kjobwidgets-${PVCUT}*:5
- =kde-frameworks/knotifications-${PVCUT}*:5
- =kde-frameworks/kservice-${PVCUT}*:5
- =kde-frameworks/ktextwidgets-${PVCUT}*:5
- =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
- =kde-frameworks/kwindowsystem-${PVCUT}*:5
- =kde-frameworks/kxmlgui-${PVCUT}*:5
- =kde-frameworks/solid-${PVCUT}*:5
- acl? (
- sys-apps/attr
- virtual/acl
- )
- handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
- kerberos? ( virtual/krb5 )
- kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
- X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
-"
-DEPEND="${RDEPEND}
- >=dev-qt/qtconcurrent-${QTMIN}:5
- test? ( sys-libs/zlib )
- X? (
- x11-base/xorg-proto
- x11-libs/libX11
- x11-libs/libXrender
- )
-"
-PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
-
-PATCHES=(
- "${FILESDIR}"/${P}-fix-copy-between-filesystems.patch
- "${FILESDIR}"/${P}-fix-KRun-open-URLs-twice.patch # KDE-bug 446272
-)
-
-src_configure() {
- local mycmakeargs=(
- -DKIO_NO_PUBLIC_QTCONCURRENT=ON
- $(cmake_use_find_package acl ACL)
- $(cmake_use_find_package handbook KF5DocTools)
- $(cmake_use_find_package kerberos GSSAPI)
- $(cmake_use_find_package kwallet KF5Wallet)
- $(cmake_use_find_package X X11)
- )
-
- ecm_src_configure
-}
-
-pkg_postinst() {
- ecm_pkg_postinst
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- ecm_pkg_postrm
- xdg_desktop_database_update
-}