summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-08-30 22:29:59 +0100
committerAmy Liffey <amynka@gentoo.org>2018-08-30 22:31:45 +0100
commite3760481155ad807f0a3c7c6007535f6952c8991 (patch)
tree3da9820e03d89b47809a26d4c121f2b481b5e89f
parentmedia-gfx/gimp: 2.10.6 (diff)
downloadgentoo-e3760481155ad807f0a3c7c6007535f6952c8991.tar.gz
gentoo-e3760481155ad807f0a3c7c6007535f6952c8991.tar.bz2
gentoo-e3760481155ad807f0a3c7c6007535f6952c8991.zip
dev-python/atomicwrites: version bump 1.2.1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-python/atomicwrites/Manifest1
-rw-r--r--dev-python/atomicwrites/atomicwrites-1.2.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/atomicwrites/Manifest b/dev-python/atomicwrites/Manifest
index 72e170e6895a..bb06756e5ec4 100644
--- a/dev-python/atomicwrites/Manifest
+++ b/dev-python/atomicwrites/Manifest
@@ -1 +1,2 @@
DIST atomicwrites-1.1.5.tar.gz 18951 BLAKE2B b0932995aae3ca23c11aace182429f4888819ea542a12b59d5b7ed4621c4759285d0cba306437bd1ce35b1ba32eac8ae6afc6548f2bae61870dbf03927c4fe75 SHA512 4de8ab93dcb226c55e8ae1b0ef883c2e1eeae50ac6596afe036ca51dbf6b094c13dbf2d792972312d4c53551886aaa2713aac54bfab42b85abef4d1146e039ac
+DIST atomicwrites-1.2.1.tar.gz 11660 BLAKE2B 06b4ca25f39be0e7e8d8e8b46749d7dce052f912e82b1ccd39e308c8ed51ab0d4891f00c11d0e52ef50901c01566f20fcf1318cb472c9a1f3a08617fd1b56235 SHA512 4df7ee97e0817a80378b273ced310b8ad88eb6ced93a594a6e3dc38ad1e7208226fde01b6d282f85583c57a50859e82c85bacaae8a7c64fce55e6965f74b12c5
diff --git a/dev-python/atomicwrites/atomicwrites-1.2.1.ebuild b/dev-python/atomicwrites/atomicwrites-1.2.1.ebuild
new file mode 100644
index 000000000000..5ca007ff2e86
--- /dev/null
+++ b/dev-python/atomicwrites/atomicwrites-1.2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Atomic file writes"
+HOMEPAGE="https://github.com/untitaker/python-atomicwrites"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}