summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-03-03 12:51:56 -0500
committerCraig Andrews <candrews@gentoo.org>2023-03-03 12:52:25 -0500
commite37e952488da9690b9e9a67a4565b6611b756c4d (patch)
tree6b34b167787c2da758f216b8f64a916dcbb0b90e
parentdev-python/pylint: Stabilize 2.16.2 ALLARCHES, #899168 (diff)
downloadgentoo-e37e9524.tar.gz
gentoo-e37e9524.tar.bz2
gentoo-e37e9524.zip
net-p2p/cpuminer-opt: add 3.21.2
Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.21.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index e940c2c5b744..3424e8099806 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.21.1.tar.gz 1791951 BLAKE2B 15137a43082f5538ac058cf5f8cf6834cd6452b3c397ab61bf2164c8859ea88de78ae73cc5533a94c050db25a2ccd777b224afd362c406e6458463c990abd259 SHA512 89f2fdbdefb27c6fbc45dab41eee7592378b0a518ef91977dabb812658b9bbdad01f5875e37cbee62fa25ee45f943f55092d89b2edd0c8196dc1566d758d3948
+DIST cpuminer-opt-3.21.2.tar.gz 1795148 BLAKE2B 8b47ee2cac3e3e6d991d99a5ff4d8e6a495629b0e9152c9a0fe8521c18b6ea113742c5e19afbd73b2bd6162145ebdd7087d49335540e8f8b4cfa8a6fadb7a096 SHA512 633a3d34bbf9f5ebf60d419f2bd44a0a0b00788a14fc6df9b835eee8880f3e3c47bb94d85c8ef21d64a6c2b9445ce67c28410b6b9bde282375597f616107a93f
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.21.2.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.2.ebuild
new file mode 100644
index 000000000000..dd862b295bd0
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.21.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:=
+ dev-libs/jansson:=
+ >=net-misc/curl-7.15[ssl]
+ dev-libs/openssl:0=
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}