summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-03 18:22:16 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-03 18:22:21 +0200
commite3935ded8f3fe6602a3d3675854b068f7c8732a4 (patch)
tree913ae3f4021c5ec008097e872db0eecf49663b04
parentsys-apps/xdg-desktop-portal-gnome: Add new portal with GNOME dependencies (diff)
downloadgentoo-e3935ded8f3fe6602a3d3675854b068f7c8732a4.tar.gz
gentoo-e3935ded8f3fe6602a3d3675854b068f7c8732a4.tar.bz2
gentoo-e3935ded8f3fe6602a3d3675854b068f7c8732a4.zip
sys-apps/xdg-desktop-portal-gtk: add 1.14.0
Backends relying on gnome are moved to xdg-desktop-portal-gtk. The appchooser and settings backends are enabled for non-GNOME GTK applications. Bug: 816135 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gtk/Manifest b/sys-apps/xdg-desktop-portal-gtk/Manifest
index e46f4f3792fa..ec586271b380 100644
--- a/sys-apps/xdg-desktop-portal-gtk/Manifest
+++ b/sys-apps/xdg-desktop-portal-gtk/Manifest
@@ -1 +1,2 @@
+DIST xdg-desktop-portal-gtk-1.14.0.tar.xz 381316 BLAKE2B 73a1e1d9944c4776ef2ebff33b26559767aad10784e9518690d31575a6216014bd0c518bde9a3b4e92d6a7edbf1aaa3510d669a025b7574c4df978f7c24b83ac SHA512 b0ba54e1ddbdfbd22b8b31bf4ece261dc0beba303e642f10afc72659dd5477438a30688c9d018e3d1ed2adbc053ddf4e3a2d70de8cac03d9519355772862fafc
DIST xdg-desktop-portal-gtk-1.8.0.tar.xz 370196 BLAKE2B d15a054e8fbc74718db7ad2d0f7b53c86b392e729fb4d5b8bdd87b16c0ebbf4feb11b29bc27da12990b351f520faa23bde694721819589513b6cfd1e4ea2f092 SHA512 832b3c4cb9ea738f2ab7641fbd7e14beaa5f6a1ae88f012cd44b12f4bc51588f61868b5982301e3dfd67965d6a69fd8669a9832b6ec7017168d611c87d76689b
diff --git a/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild
new file mode 100644
index 000000000000..9e8da15268bc
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+MY_PV="${PV//_pre*}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GTK+"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal-gtk"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.14.0
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # As done in Fedora:
+ # All backends that are disabled are instead provided by
+ # xdg-desktop-portal-gnome to keep this package free of GNOME dependencies.
+ # The appchooser and settings backends are enabled for non-GNOME GTK
+ # applications.
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --enable-appchooser
+ --enable-settings
+ --disable-background
+ --disable-lockdown
+ --disable-screencast
+ --disable-screenshot
+ --disable-wallpaper
+ )
+
+ econf "${myeconfargs[@]}"
+}