summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-24 15:51:06 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-24 15:51:06 +0100
commite3a80ce04c0cfafdeadbb1ba8a08ddcc925ad7d9 (patch)
tree96e2528d7eef22dce278b3c00b667ecfdcb75e6c
parentdev-db/mariadb-connector-c: bump to v3.1.12 (diff)
downloadgentoo-e3a80ce04c0cfafdeadbb1ba8a08ddcc925ad7d9.tar.gz
gentoo-e3a80ce04c0cfafdeadbb1ba8a08ddcc925ad7d9.tar.bz2
gentoo-e3a80ce04c0cfafdeadbb1ba8a08ddcc925ad7d9.zip
net-misc/teamviewer: bump to v15.15.5
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/teamviewer-15.15.5.ebuild136
2 files changed, 138 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index 0c0497b2c0e6..5e6c717eb88c 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -2,3 +2,5 @@ DIST teamviewer_15.14.3_amd64.tar.xz 13216052 BLAKE2B d5fa55609a2bb6257c1fc95ec9
DIST teamviewer_15.14.3_i386.tar.xz 13733488 BLAKE2B 14def908b2c2e86b49649264b0eab4b15594e15425b98333720f0025a0530cf3e2c350f54b996f6d48a6f44dd368899fec95c38ddeb6b909992fecf80a2bdc46 SHA512 02a2843424a19252546ce0598f0ec52dd4a0d02148e379c944b7976bba794858cc1ca58724bf5b9828b6dd38e3f3989bab8b17d7ca9285596fd450d2ce753668
DIST teamviewer_15.14.5_amd64.tar.xz 13224544 BLAKE2B 2cefeebce0a4c31ba84e554882400ee65b6a44d7c335125cd25dfd4e9e4aa02b34708d679873a52b31e46c5157ac7d6a89d8b77848453fc7733f8931964202fc SHA512 723a63d9490df367c3f072da9ed79d84e38de60c67ca78c10b01612f48fe1afe0d379b414f898f342ddab336b9689d2f38b76d9ff83654a789e8059b2da886ad
DIST teamviewer_15.14.5_i386.tar.xz 13724612 BLAKE2B 09558e5bc3b5db9ac57a038af14eb56816a5f272a637cfb3f73bfe072836a3011ff14f5e8acdd50889d66a9422fdc0d14f50eccfa908c6e796544d93f30961ed SHA512 5c38cd3106adf69c6b27d8696ff6c3d49a1a1450e317b07af20e7b2c2351102fcd6a0d61a9e1ce1f75968db048461adcb3dd5d5b0cf98b3de94719ccfed93586
+DIST teamviewer_15.15.5_amd64.tar.xz 13264432 BLAKE2B 8f23c036b79c7ee7cbef1181825b5605afd77f22d0565e5359c928bd4014759c3ad56255d8e76ba75d3084c8a9bed98fcdd08f20e502c2906e6eaf6dd952a7b4 SHA512 e42cccb74c08ef1badcd4b78016078a9f6f3b69b700e4c64d6eae927fa4b748c11288ef5cc50aa962eabd17679479ececf8750e8c34f6361758da903e555a334
+DIST teamviewer_15.15.5_i386.tar.xz 13751236 BLAKE2B 32d8f6494c72b51feef54e2d5dd1096aee83c283a1d07680f428bd4321ede9975d1ee4e7cd55718f9250d54304d17887b98ae6e62617e7022ec78384fdde5a16 SHA512 315e6fcaa6d40aab17c47ac4eee6d894be3731ae7d0242e2b11bae279627de04540f8d46908826d53b6a6d275769c19a420c6f30e9869a734e87cb7d6832bfba
diff --git a/net-misc/teamviewer/teamviewer-15.15.5.ebuild b/net-misc/teamviewer/teamviewer-15.15.5.ebuild
new file mode 100644
index 000000000000..4636957e3f98
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-15.15.5.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN}${PV/\.*}
+inherit desktop systemd xdg
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+ !sys-auth/consolekit
+"
+
+# For consolekit incompatibility see https://forums.gentoo.org/viewtopic-p-8332956.html#8332956
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+ sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+ -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+ local dst="/opt/${MY_PN}" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ # No slotting here, binary expects this service path
+ newinitd "${FILESDIR}"/teamviewerd15.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+ done
+
+ # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+ # have the undesired result of installing subdirectory 'doc' in /usr/
+ # share/doc/teamviewer-<version>)
+ for doc in $(find doc -type f); do
+ dodoc ${doc}
+ done
+
+ keepdir /etc/${MY_PN}
+ dosym ../../etc/${MY_PN} ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/${MY_PN}
+ dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+
+ elog "Please note that parallel installation of multiple versions of"
+ elog "TeamViewer is currently not supported at runtime. Bug #621818"
+ elog ""
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ teamviewer help"
+ elog
+ elog "Most likely TeamViewer will work normally only on systems with systemd"
+ elog "or elogind. See this thread for additional info:"
+ elog "https://forums.gentoo.org/viewtopic-p-8332956.html#8332956"
+ fi
+}