summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-02-25 11:02:13 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-02-25 11:02:32 +0100
commite3b1fe69b9d655655c64b6d4c03fcb317e16a1ac (patch)
treefdd90381ac7efcddce519877ca180b4902508fa4
parentdev-libs/libfilezilla: Bump to version 0.20.1. Removed old (diff)
downloadgentoo-e3b1fe69.tar.gz
gentoo-e3b1fe69.tar.bz2
gentoo-e3b1fe69.zip
net-ftp/filezilla: Bump to version 3.47.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/files/filezilla-3.47.0-metainfo.patch11
-rw-r--r--net-ftp/filezilla/filezilla-3.47.0.ebuild87
3 files changed, 99 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index 877c43cd2093..e72b8e28aa10 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -3,3 +3,4 @@ DIST FileZilla_3.44.2_src.tar.bz2 4619337 BLAKE2B 11d61b14fcf464706dabe491fa8cbf
DIST FileZilla_3.45.1_src.tar.bz2 4649083 BLAKE2B 8d3113e5ce96d2115a6ec02109f2617d3d58109464c527284baecacea733d2f564206779cd32be4060171d7fcd8768b0296b445842b8c2964b173ca360983082 SHA512 feb267b85ad2843baea0c6df66ed86866121f33e2295fcb9003a8bc2603ad684f4fe801ea842cb291e3fb5cd7195ccb2d21bfa95711a61be6b4debfd4e1c7822
DIST FileZilla_3.46.0_src.tar.bz2 4661100 BLAKE2B ccda60b590e85afd7de0edd064ee7b993e663e43643f262378db6d26a019730ec493518e0e2b39bce0710acafe888f47f84ecb098e35d3b32061f089a99a6a30 SHA512 26ffb039b4a6d51d6d1011ee452f3690f74514c91a9e58c79880dbf778296cfc81283fade52f65f81654b828449e2b7e703b1d6c1e2e84c08f54681d2aa92674
DIST FileZilla_3.46.3_src.tar.bz2 4720329 BLAKE2B 92369d2fb3b8c9eded37f912bbd25a0e995a5fc1ab86ef6aa746a8eb239f17e8fafa78de00529b0f3af102fe268b51a60ce40ac967cf9b2fbbd6fa7900898ffc SHA512 35b61c3bfd1d40848e7846b4533da8844df0e4873cb89286b90330cbc29dffeff96fcab10aec908a08d9129198bb2d80df8f223d8ebc1a0863a4083cb06abffc
+DIST FileZilla_3.47.0_src.tar.bz2 4732662 BLAKE2B 02b3b16b41b6c7dc19f3349d14414023dfd900b5cc592b44a89a27541a3c4c0e876be59089d202e4b2938b2eb8b96d6e1b25501f16d5d3bcfd6477b744535728 SHA512 6b2089da271411552524621f6635857f37c42e1e67978337b02d2d26ee5f31e5895636158f647aaa184213d6ddfcf45d8320da1b7e52549bd5adbf62b6ebf22d
diff --git a/net-ftp/filezilla/files/filezilla-3.47.0-metainfo.patch b/net-ftp/filezilla/files/filezilla-3.47.0-metainfo.patch
new file mode 100644
index 000000000000..309c66815e3c
--- /dev/null
+++ b/net-ftp/filezilla/files/filezilla-3.47.0-metainfo.patch
@@ -0,0 +1,11 @@
+--- filezilla-3.47.0/data/Makefile.am
++++ filezilla-3.47.0/data/Makefile.am
+@@ -75,7 +75,7 @@
+ desktopentrydir = $(datadir)/applications
+ dist_desktopentry_DATA = filezilla.desktop
+
+-appdatadir = $(datadir)/appdata
++appdatadir = $(datadir)/metainfo
+ dist_appdata_DATA = filezilla.appdata.xml
+
+ clean-local:
diff --git a/net-ftp/filezilla/filezilla-3.47.0.ebuild b/net-ftp/filezilla/filezilla-3.47.0.ebuild
new file mode 100644
index 000000000000..9f99a47ff441
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.47.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.20.0:=
+ <dev-libs/libfilezilla-0.21.0:=
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+ "${FILESDIR}"/${PN}-3.47.0-metainfo.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}