summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-12-16 17:30:34 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-12-16 17:38:53 +0100
commite3c009c05c516a28830c0d0213e324ed492d2d77 (patch)
tree783b6cecde06bb7d9eca5f5140acbf7e4aade9af
parentdev-java/tomcat-jsp-api: Stabilize 9.0.69 arm64, #886283 (diff)
downloadgentoo-e3c009c05c516a28830c0d0213e324ed492d2d77.tar.gz
gentoo-e3c009c05c516a28830c0d0213e324ed492d2d77.tar.bz2
gentoo-e3c009c05c516a28830c0d0213e324ed492d2d77.zip
dev-java/coursier-bin: add 2.1.0_rc3
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/coursier-bin/Manifest1
-rw-r--r--dev-java/coursier-bin/coursier-bin-2.1.0_rc3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/coursier-bin/Manifest b/dev-java/coursier-bin/Manifest
index d221834ae1ef..ca7181e4bdd3 100644
--- a/dev-java/coursier-bin/Manifest
+++ b/dev-java/coursier-bin/Manifest
@@ -1 +1,2 @@
DIST coursier-bin-2.1.0_rc2.gz 21077153 BLAKE2B 19ff645670b3f94162672b669063491f10e4ae8aee645fe0205f4f0dc80e9380ab045c665cdca792d93f1723348c8d267b01bfabc4db5014765757417d1cdc6e SHA512 9b822f8642a10afe7933c8f7bf246aea73b42e0d6ef5db0f9e4f9edee96a31a3d00111a8e1ba2e77898135131b6158dd3be5ca5ba3bac9ca95866aef881e5b80
+DIST coursier-bin-2.1.0_rc3.gz 21120545 BLAKE2B 55d4236c408b9883d49fa64ed79f269fc935171abe161c3bef8e92da396f12881c9cf7750dd8e8d5b955c390cfb29304a8406c3db702c3a477219acbf0c0b989 SHA512 1a31d7ced6c8c1137b6e330723c90e12f010a815592a4e11129c7bd5611528edc62166415937c6fa5dc92732b277bce1b971e6dee27f9b1350ac71b4b7afc290
diff --git a/dev-java/coursier-bin/coursier-bin-2.1.0_rc3.ebuild b/dev-java/coursier-bin/coursier-bin-2.1.0_rc3.ebuild
new file mode 100644
index 000000000000..32691c5ffc9b
--- /dev/null
+++ b/dev-java/coursier-bin/coursier-bin-2.1.0_rc3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+get_orig_coursier_pv() {
+ local orig_pv=$(ver_rs 3 -)
+ orig_pv=${orig_pv/rc/RC}
+ orig_pv=${orig_pv/pre/M}
+ echo "${orig_pv}"
+}
+
+DESCRIPTION="Java/Scala artifact fetching, bundling and deploying"
+HOMEPAGE="https://get-coursier.io/"
+SRC_URI="https://github.com/coursier/coursier/releases/download/v$(get_orig_coursier_pv)/cs-x86_64-pc-linux.gz -> ${P}.gz"
+
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-8"
+
+QA_FLAGS_IGNORED="usr/bin/coursier"
+QA_TEXTRELS="usr/bin/coursier"
+
+src_install() {
+ newbin "${P}" coursier
+}