summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 17:53:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:17:08 +0300
commite3c331fefc0ffd90be24de6d9f33aede5346a7ff (patch)
tree2b97900500b7c3c7515d69a925595f91423782f6
parentdev-python/pathable: new package, add 0.4.3 (diff)
downloadgentoo-e3c331fe.tar.gz
gentoo-e3c331fe.tar.bz2
gentoo-e3c331fe.zip
dev-python/jsonschema-spec: new package, add 0.1.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jsonschema-spec/Manifest1
-rw-r--r--dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild36
-rw-r--r--dev-python/jsonschema-spec/metadata.xml13
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/jsonschema-spec/Manifest b/dev-python/jsonschema-spec/Manifest
new file mode 100644
index 000000000000..738a8b87f272
--- /dev/null
+++ b/dev-python/jsonschema-spec/Manifest
@@ -0,0 +1 @@
+DIST jsonschema-spec-0.1.1.gh.tar.gz 21747 BLAKE2B 441f34c62da2d22699379035e20f2ed78a974413ea9c2f80b753cc2b41d978351c69aaa50750139e622d075c4c3979dc43b888bea111a0f4b31fa9d37822a1fa SHA512 b1bdd03c6fc022877d0801d859abe0dd19e066afe2a1eab6c650a8741a50473e74945ddde429508e5dccf379a84b25fbd60c49fdc310aa770bed52b63e60e397
diff --git a/dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild b/dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild
new file mode 100644
index 000000000000..fd24a7a9a068
--- /dev/null
+++ b/dev-python/jsonschema-spec/jsonschema-spec-0.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-spec/
+ https://github.com/p1c2u/jsonschema-spec
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-spec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/pathable[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/--cov/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/jsonschema-spec/metadata.xml b/dev-python/jsonschema-spec/metadata.xml
new file mode 100644
index 000000000000..1559254c1a65
--- /dev/null
+++ b/dev-python/jsonschema-spec/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jsonschema-spec</remote-id>
+ <remote-id type="github">p1c2u/jsonschema-spec</remote-id>
+ </upstream>
+</pkgmetadata>