summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-26 00:39:58 -0500
committerSam James <sam@gentoo.org>2021-02-27 03:06:22 +0000
commite3ce84f8ab5ddb789fb8afd1c46743c58a62722f (patch)
tree24cf18fbd3548c4fabb673d658a44365cf37f69e
parentsci-libs/coinor-blis: add github remote-id (diff)
downloadgentoo-e3ce84f8ab5ddb789fb8afd1c46743c58a62722f.tar.gz
gentoo-e3ce84f8ab5ddb789fb8afd1c46743c58a62722f.tar.bz2
gentoo-e3ce84f8ab5ddb789fb8afd1c46743c58a62722f.zip
sci-libs/coinor-blis: bump to 0.94.8, ported to EAPI 7
Has reworked old workarounds and reviewed deps, notably the missing coinor-cgl dep (bug #514532). USE=examples removed, now installed unconditionally (small files). USE=doc added to install html docs. USE=static-libs removed. Closes: https://bugs.gentoo.org/514532 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/coinor-blis/Manifest1
-rw-r--r--sci-libs/coinor-blis/coinor-blis-0.94.8.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-libs/coinor-blis/Manifest b/sci-libs/coinor-blis/Manifest
index e3ca8b945e1a..671064a6a5fb 100644
--- a/sci-libs/coinor-blis/Manifest
+++ b/sci-libs/coinor-blis/Manifest
@@ -1 +1,2 @@
DIST Blis-0.93.10.tgz 10612207 BLAKE2B aaef129ca4de7aba8131c46d7619accd8087abb13e183e9caafdada20636b2d5769b88c0195db0194bbd2d60ada4209609716e8b08436f8c43e62807b325ff68 SHA512 ef4c1b7704353e9d2628401d9a47e72d0b26d485ac3951b03fe84fdc98cfbee8e3b9f3412411eca693c8e00bdf97798e08c4dabcf5b8646bbe3d8481c237820e
+DIST coinor-blis-0.94.8.tar.gz 4186086 BLAKE2B 6be1ea6f27913cf128947225b2d03b071ee20bc35f49ea319f5ed8ed77d2d89fac0a66bf2b5204ec4194c1a8444033c7ee797ac5c0adbc0572f9195d9a357735 SHA512 5b401eaf7b80af6cb724606655c38811918e92ae89d2f4a1fd5f318bdc8fa1463175a106c2f3ab43bf5eda677a6d7bbdb8a0f8bc0155135108a10bbcbb93070b
diff --git a/sci-libs/coinor-blis/coinor-blis-0.94.8.ebuild b/sci-libs/coinor-blis/coinor-blis-0.94.8.ebuild
new file mode 100644
index 000000000000..dcc2f33bd47e
--- /dev/null
+++ b/sci-libs/coinor-blis/coinor-blis-0.94.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="COIN-OR BiCePS Linear Integer Solver"
+HOMEPAGE="https://projects.coin-or.org/CHiPPS/"
+SRC_URI="https://github.com/coin-or/CHiPPS-BLIS/archive/releases/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/CHiPPS-BLIS-releases-${PV}/Blis"
+
+LICENSE="EPL-1.0"
+SLOT="0" # formerly 0/1, upstream went from so.1 to so.0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-libs/coinor-alps:=
+ sci-libs/coinor-bcps:=
+ sci-libs/coinor-cgl:=
+ sci-libs/coinor-clp:=
+ sci-libs/coinor-osi:=
+ sci-libs/coinor-utils:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+ test? ( sci-libs/coinor-sample )"
+
+src_prepare() {
+ default
+ # Prevent unneeded call to pkg-config that needs ${ED}'s in path.
+ sed -i '/--libs.*addlibs.txt/d' Makefile.in || die
+
+ gzip -d examples/data/{,hard/}*.gz || die
+}
+
+src_configure() {
+ econf $(use_with doc dot)
+}
+
+src_compile() {
+ emake all $(usex doc doxydoc '')
+}
+
+src_test() {
+ # Needed given "make check" is a noop and it skips the working one.
+ emake test
+}
+
+src_install() {
+ default
+ dodoc -r examples
+ use doc && dodoc -r doxydoc/html
+
+ # Duplicate or irrelevant files.
+ rm -r "${ED}"/usr/share/coin/doc || die
+ find "${ED}" -name '*.la' -delete || die
+}