summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-11-21 10:39:03 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-11-21 13:20:40 -0500
commite3d454169a24723b010acdb3639043ddfacd00f2 (patch)
tree333e83dfe817135a4f767bf11b42ed4fc886d59b
parentdev-ruby/faker: new metasploit dep (diff)
downloadgentoo-e3d45416.tar.gz
gentoo-e3d45416.tar.bz2
gentoo-e3d45416.zip
dev-ruby/metasploit-model: bump
cleanup, bump, add x86 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--dev-ruby/metasploit-model/Manifest1
-rw-r--r--dev-ruby/metasploit-model/metasploit-model-2.0.3.ebuild6
-rw-r--r--dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild72
3 files changed, 76 insertions, 3 deletions
diff --git a/dev-ruby/metasploit-model/Manifest b/dev-ruby/metasploit-model/Manifest
index c5df9558036f..56749e457d43 100644
--- a/dev-ruby/metasploit-model/Manifest
+++ b/dev-ruby/metasploit-model/Manifest
@@ -1 +1,2 @@
DIST metasploit-model-2.0.3.gem 81408 BLAKE2B e62074efbdd66fc951b4c304d9c0adbf54b631bf0e343658b395e76bf4783db8a0186f375ce2650110b2200b805832ae25cd81779d894c1b7475a07d3041b35a SHA512 a6d77940e6b85925cc93c57f69910fde5c8eb2458d6707847be9f5856cfceee33304209e8c7076484151d9daf1f23cfe28cb0c00abb83176b7bc6c819fb128ec
+DIST metasploit-model-2.0.4.gem 81408 BLAKE2B 5a4be9e61649710470618d4334279054cbefc1027a1d4674b6be0c6a4c632219fd2dc3ac5f9f56dc9018712e5cbcbe191d5749ed2ed10cf98f884a06e41ec736 SHA512 70f6d948227bc99f877c3b5631a964087c0ebfdb091f128c72bc5da276bf57a5055aea5cdda4dc66e1fb177606afec9b7b3ee4076211f43928a2defb93294ac5
diff --git a/dev-ruby/metasploit-model/metasploit-model-2.0.3.ebuild b/dev-ruby/metasploit-model/metasploit-model-2.0.3.ebuild
index 8ffc7598d3c7..00924336d8ec 100644
--- a/dev-ruby/metasploit-model/metasploit-model-2.0.3.ebuild
+++ b/dev-ruby/metasploit-model/metasploit-model-2.0.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
USE_RUBY="ruby23"
-inherit ruby-fakegem versionator
+inherit ruby-fakegem eapi7-ver
RUBY_FAKEGEM_EXTRAINSTALL="app config script spec"
@@ -13,7 +13,7 @@ HOMEPAGE="https://github.com/rapid7/metasploit-model"
SRC_URI="mirror://rubygems/${P}.gem"
LICENSE="BSD"
-SLOT="$(get_version_component_range 1-2)"
+SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm"
#IUSE="development test"
RESTRICT=test
diff --git a/dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild b/dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild
new file mode 100644
index 000000000000..d3b004a03f63
--- /dev/null
+++ b/dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24"
+
+inherit ruby-fakegem eapi7-ver
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config script spec"
+
+DESCRIPTION="Common code, such as validators and mixins"
+HOMEPAGE="https://github.com/rapid7/metasploit-model"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+LICENSE="BSD"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+#IUSE="development test"
+RESTRICT=test
+IUSE=""
+
+RDEPEND="${RDEPEND} !dev-ruby/metasploit-model:0"
+
+ruby_add_rdepend ">=dev-ruby/railties-4.2.6:4.2
+ >=dev-ruby/activesupport-4.2.6:4.2
+ >=dev-ruby/activemodel-4.2.6:4.2"
+# development? ( dev-ruby/bundler
+# dev-ruby/rake
+# dev-ruby/i18n
+# dev-ruby/multi_json
+# dev-ruby/builder
+# dev-ruby/erubis
+# dev-ruby/journey
+# dev-ruby/rack
+# dev-ruby/rack-cache
+# dev-ruby/rack-test
+# dev-ruby/hike
+# dev-ruby/tilt
+# dev-ruby/sprockets:*
+# dev-ruby/actionpack:4.0
+# dev-ruby/json
+# dev-ruby/rack-ssl:*
+# dev-ruby/rdoc
+# dev-ruby/thor
+# dev-ruby/redcarpet
+# <dev-ruby/yard-0.8.7.4 )"
+
+ruby_add_bdepend "dev-ruby/bundler"
+
+all_ruby_prepare() {
+ [ -f Gemfile.lock ] && rm Gemfile.lock
+ #For now, we don't support development or testing at all
+ #if ! use development; then
+ sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
+ sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
+ sed -i -e "/spec.add_development_dependency/d" "${PN}".gemspec || die
+ #fi
+ #if ! use test; then
+ sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
+ #fi
+ #if ! use test && ! use development; then
+ sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
+ #fi
+}
+
+each_ruby_prepare() {
+ if [ -f Gemfile ]
+ then
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
+ BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
+ fi
+}