summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-03-18 11:54:02 -0300
committerMatt Turner <mattst88@gentoo.org>2023-03-18 23:51:29 -0400
commite3eaf25e37ecf443e0ba1db502103bc3fa73f71f (patch)
tree9b199f7baf5fc06423f39e8c140b0941bfbd93dc
parentsci-geosciences/gnome-maps: Version bump to 43.5 (diff)
downloadgentoo-e3eaf25e37ecf443e0ba1db502103bc3fa73f71f.tar.gz
gentoo-e3eaf25e37ecf443e0ba1db502103bc3fa73f71f.tar.bz2
gentoo-e3eaf25e37ecf443e0ba1db502103bc3fa73f71f.zip
sci-geosciences/gnome-maps: Version bump to 44.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30206 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild b/sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild
new file mode 100644
index 000000000000..b7701c61f77d
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-44.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}