summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-16 22:07:41 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-16 22:26:39 +0200
commite40c6a1c8a43387e19e4afdf84d8e6d3cf4eb787 (patch)
tree3cac99e9687605c97961f9e2655a73463a29fa4c
parentgames-arcade/gish-demo: Drop old (diff)
downloadgentoo-e40c6a1c8a43387e19e4afdf84d8e6d3cf4eb787.tar.gz
gentoo-e40c6a1c8a43387e19e4afdf84d8e6d3cf4eb787.tar.bz2
gentoo-e40c6a1c8a43387e19e4afdf84d8e6d3cf4eb787.zip
games-arcade/gnake: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--games-arcade/gnake/gnake-0.94b-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/gnake/gnake-0.94b-r1.ebuild b/games-arcade/gnake/gnake-0.94b-r1.ebuild
new file mode 100644
index 000000000000..a1cce857258b
--- /dev/null
+++ b/games-arcade/gnake/gnake-0.94b-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="An ncurses-based Nibbles clone"
+HOMEPAGE="http://lightless.org/gnake"
+SRC_URI="mirror://gentoo/Gnake.${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake LDLIBS="$(pkg-config ncurses --libs)" gnake
+}
+
+src_install() {
+ dobin gnake
+ einstalldocs
+}