summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-02-21 14:53:58 -0600
committerWilliam Hubbs <williamh@gentoo.org>2021-02-21 14:53:58 -0600
commite437ac571211cd33c268dcd1b1f70e75f6a47b3a (patch)
tree0db10a5106abe79bc5fd041bc08acefec444a95d
parentdev-python/hvac: Hashicorp vault client in python (diff)
downloadgentoo-e437ac571211cd33c268dcd1b1f70e75f6a47b3a.tar.gz
gentoo-e437ac571211cd33c268dcd1b1f70e75f6a47b3a.tar.bz2
gentoo-e437ac571211cd33c268dcd1b1f70e75f6a47b3a.zip
app-admin/ansible-modules-hashivault: ansible module for hashicorp vault
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-admin/ansible-modules-hashivault/Manifest1
-rw-r--r--app-admin/ansible-modules-hashivault/ansible-modules-hashivault-4.6.2.ebuild29
-rw-r--r--app-admin/ansible-modules-hashivault/metadata.xml12
3 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/ansible-modules-hashivault/Manifest b/app-admin/ansible-modules-hashivault/Manifest
new file mode 100644
index 000000000000..689772244be2
--- /dev/null
+++ b/app-admin/ansible-modules-hashivault/Manifest
@@ -0,0 +1 @@
+DIST ansible-modules-hashivault-4.6.2.tar.gz 71795 BLAKE2B 3a989123bb3ff6e9556291a828b678dc02ca068f0ffc893b289c90b77479b0da0243bcc94134aa911cb40bd91b37c816b41b730cd39492ad8fa8d557469dd99d SHA512 d9d2b9089a632d3f9ebeaa5554ad27eff4a3b7be8f9b119dbfa787b886fe113afb6ffc7f3219dcded1a05976f5247c33d1e235c1cb0a75619dffbbc0a93e0270
diff --git a/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-4.6.2.ebuild b/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-4.6.2.ebuild
new file mode 100644
index 000000000000..a586324f0f02
--- /dev/null
+++ b/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-4.6.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_8 )
+inherit distutils-r1
+
+DESCRIPTION="Ansible module for hashicorp vault"
+HOMEPAGE="https://ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/TerryHowe/ansible-modules-hashivault.git"
+else
+ SRC_URI="https://github.com/TerryHowe/ansible-modules-hashivault/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-admin/ansible-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/hvac-0.9.5[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+# The tests require a private instance of vault
+RESTRICT="test"
diff --git a/app-admin/ansible-modules-hashivault/metadata.xml b/app-admin/ansible-modules-hashivault/metadata.xml
new file mode 100644
index 000000000000..a2de45549bab
--- /dev/null
+++ b/app-admin/ansible-modules-hashivault/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>