summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-01-04 13:09:58 -0600
committerMatthias Maier <tamiko@gentoo.org>2022-01-04 13:11:05 -0600
commite43d09e935ef6867fccf383eb047f792da441798 (patch)
treef3b82542359cf3d5589204de5f2db81c4c0368df
parentx11-terms/kitty: update live and add no-rc issue link (diff)
downloadgentoo-e43d09e9.tar.gz
gentoo-e43d09e9.tar.bz2
gentoo-e43d09e9.zip
dev-libs/openspecfun: add patch
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
-rw-r--r--dev-libs/openspecfun/files/openspecfun-0.5.5-Makefile.patch68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/openspecfun/files/openspecfun-0.5.5-Makefile.patch b/dev-libs/openspecfun/files/openspecfun-0.5.5-Makefile.patch
new file mode 100644
index 000000000000..3544d8197a2e
--- /dev/null
+++ b/dev-libs/openspecfun/files/openspecfun-0.5.5-Makefile.patch
@@ -0,0 +1,68 @@
+--- a/Make.inc
++++ b/Make.inc
+@@ -14,41 +14,18 @@ bindir = $(prefix)/bin
+ libdir = $(prefix)/lib
+ includedir = $(prefix)/include
+
+-FC = gfortran
+ # CFLAGS_add and FFLAGS_add are flags that we always want to include
+ # They are not overridable by the user, whereas CFLAGS and FFLAGS are
+ # simply defaults and are overridable via environment variables or
+ # `make CFLAGS="foo"` on the command line
+
+-FFLAGS = -O3 -fno-optimize-sibling-calls
+-CFLAGS = -std=c99 -O3
+-CPPFLAGS =
++CFLAGS += -std=c99 -Wall
+
+ override FFLAGS_add =
+ override CFLAGS_add =
+ override CPPFLAGS_add =
+ override LDFLAGS_add =
+
+-USEGCC = 1
+-USECLANG = 0
+-
+-ifneq (,$(findstring $(OS),FreeBSD Darwin))
+-USEGCC = 0
+-USECLANG = 1
+-endif
+-
+-AR = ar
+-
+-ifeq ($(USECLANG),1)
+-USEGCC = 0
+-CC = clang
+-override CFLAGS_add += -fno-builtin
+-endif
+-
+-ifeq ($(USEGCC),1)
+-CC = gcc
+-override CFLAGS_add += -fno-gnu89-inline -std=c99
+-endif
+
+ ARCH := $(shell $(CC) -dumpmachine | sed "s/\([^-]*\).*$$/\1/")
+ ifeq ($(ARCH),mingw32)
+diff --git a/Makefile b/Makefile
+index 7b028b8..c30ed98 100644
+--- a/Makefile
++++ b/Makefile
+@@ -35,9 +35,7 @@ OSF_MAJOR_SHLIB_EXT := $(SHLIB_EXT).$(SOMAJOR)
+ endif
+ endif
+
+-all: libopenspecfun.a libopenspecfun.$(OSF_MAJOR_MINOR_SHLIB_EXT)
+-libopenspecfun.a: $(OBJS)
+- $(AR) -rcs libopenspecfun.a $(OBJS)
++all: libopenspecfun.$(OSF_MAJOR_MINOR_SHLIB_EXT)
+ libopenspecfun.$(OSF_MAJOR_MINOR_SHLIB_EXT): $(OBJS)
+ $(FC) -shared $(OBJS) $(LDFLAGS) $(LDFLAGS_add) -Wl,$(SONAME_FLAG),libopenspecfun.$(OSF_MAJOR_SHLIB_EXT) -o $@
+ ifneq ($(OS),WINNT)
+@@ -50,7 +48,6 @@ install: all
+ mkdir -p $(DESTDIR)$(libdir)
+ mkdir -p $(DESTDIR)$(includedir)
+ cp -a libopenspecfun.*$(SHLIB_EXT)* $(DESTDIR)$(shlibdir)/
+- cp -a libopenspecfun.a $(DESTDIR)$(libdir)/
+ cp -a Faddeeva/Faddeeva.h $(DESTDIR)$(includedir)
+
+ clean: