summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-04 06:27:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-04 06:48:43 +0200
commite44115cda42f40c074510f8aaabdb33f67a804c2 (patch)
treecc6548bc59573e69b5de751be74451840f3f757e
parentdev-python/fakeredis: Bump to 2.10.3 (diff)
downloadgentoo-e44115cd.tar.gz
gentoo-e44115cd.tar.bz2
gentoo-e44115cd.zip
dev-python/nbconvert: Bump to 7.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbconvert/Manifest1
-rw-r--r--dev-python/nbconvert/nbconvert-7.3.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 17b836706ef8..4a712b9921e1 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -1,2 +1,3 @@
DIST nbconvert-7.2.10.tar.gz 870708 BLAKE2B 837b5cf70f530b8fd3d566809d8d4faefdb3c4581b46e317d218a08bb06b80fdf59dcbd6c337b7fd62a9fdff676ea1cec941a7f6641c54ebee066a1bec19ffcd SHA512 078d6f1375f595f30db9eeebab55842353d549a294290a185c3817fc0bb2459c392120f089890409eec7cfe0fec7909752d20e4c55123249a4685d34655e0c05
DIST nbconvert-7.2.9.tar.gz 870386 BLAKE2B aea62f29d3e696c70d77ab73cc89347a4e0c8e077e98c45331608f7117fb3c98165bf3da89e4f3bf23b9d62c618289d98c9103c5b2998ca81f65cbfda65ca536 SHA512 0053e0e88f279d2fe430e516bcc19f98191e9ce414546ab1ff214f37c8f1cdfc4fc101faa4b5f1d5955fdc65c87aad367f5a5f12ce5991c68c015c5083f2f30c
+DIST nbconvert-7.3.0.tar.gz 879918 BLAKE2B cf1414f5c6a41222f576a66ca8aa49f98d5ee4a0cd6bedcd779a6c429d46550e0435e60723255358f1ccf51b508d74e7461521889cbb7e6dfb10377175ea78a2 SHA512 a7030cced31ae749d9625f7fb7cc2bee17c10fcd90e83f36efed1c00758d02e47ed9d90aa907c2acbe979810a561d48d9fe854a3786b60418beacdd471b14b8f
diff --git a/dev-python/nbconvert/nbconvert-7.3.0.ebuild b/dev-python/nbconvert/nbconvert-7.3.0.ebuild
new file mode 100644
index 000000000000..f8c9b4fd4ccd
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.3.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing pypi virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~riscv ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.9)
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mistune-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mkdir -p share/templates/classic/static || die
+ # tries to refetch stuff even if it's already present
+ sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
+ -i hatch_build.py || die
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Missing pyppeteer for now
+ # TODO: Doesn't skip?
+ nbconvert/exporters/tests/test_webpdf.py
+ # Needs pyppeteer too
+ 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ # TODO
+ nbconvert/exporters/tests/test_qtpng.py::TestQtPNGExporter::test_export
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ # latex failing, might be too new pandoc
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_filename_spaces
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_pdf
+ # too new pandoc but we don't have old anymore
+ nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_minimal_version
+ nbconvert/utils/tests/test_pandoc.py::TestPandoc::test_pandoc_available
+ )
+
+ # virtx implies nonfatal, make it explicit to avoid confusion
+ nonfatal epytest -n "$(makeopts_jobs)" --pyargs nbconvert || die
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc && ! has_version app-text/pandoc-bin; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc or app-text/pandoc-bin."
+ fi
+}