summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-01 01:09:07 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-01 01:09:23 +0000
commite44dae02c63606fb91237a84e1a7d0810ab2698e (patch)
treeb08207adcad610708b34dd83e31fd0f8f0b96562
parentsys-kernel/gentoo-sources: Linux patch 3.10.96. Linux patch 3.12.53. Linux pa... (diff)
parentdev-python/blessings: add py3.5, fix tests (diff)
downloadgentoo-e44dae02.tar.gz
gentoo-e44dae02.tar.bz2
gentoo-e44dae02.zip
Merge remote-tracking branch 'github/pr/744'.
-rw-r--r--dev-python/blessings/blessings-1.6.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/blessings/blessings-1.6.ebuild b/dev-python/blessings/blessings-1.6.ebuild
index a7c135ae3b49..7a08c1be567c 100644
--- a/dev-python/blessings/blessings-1.6.ebuild
+++ b/dev-python/blessings/blessings-1.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{3,4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
@@ -17,9 +17,11 @@ LICENSE="MIT"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
-DEPEND="dev-python/nose[${PYTHON_USEDEP}]"
-RDEPEND=""
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
- nosetests --verbosity=3 ${PN} || die
+ # The tests need an interactive terminal
+ # https://github.com/erikrose/blessings/issues/117
+ script -eqc "nosetests -w \"${BUILD_DIR}\"" /dev/null \
+ || die "tests failed with ${EPYTHON}"
}