summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Eisele <kernlpanic@dennis-eisele.de>2022-01-13 01:41:24 +0100
committerSam James <sam@gentoo.org>2022-01-20 14:29:48 +0000
commite471cf64fdc3f2518a0bc3eac33e6da43f44257b (patch)
tree58ea7d38a15e0515c92c56b90bdb27c12ef91acf
parentapp-editors/diakonos: bump to version 0.9.7 (diff)
downloadgentoo-e471cf64.tar.gz
gentoo-e471cf64.tar.bz2
gentoo-e471cf64.zip
media-sound/flacon: bump version to 8.2.0
Closes: https://bugs.gentoo.org/753164 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Dennis Eisele <kernlpanic@dennis-eisele.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/flacon/Manifest1
-rw-r--r--media-sound/flacon/flacon-8.2.0.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/media-sound/flacon/Manifest b/media-sound/flacon/Manifest
index 481e306c2b87..a862fd500a7f 100644
--- a/media-sound/flacon/Manifest
+++ b/media-sound/flacon/Manifest
@@ -1 +1,2 @@
DIST flacon-5.5.1.tar.gz 2336502 BLAKE2B 524fe5fa28126f56452515ca1ce1572343dad8b06c28fc8e3a22a11e9ad8f3a51a25b3c19ddd29a7e3c658f1d7fb3316a2554a12a4ba3dd22370fc1394d38022 SHA512 36900b011135b61cf3cc1f05d94f852fc7e127972f3fed09e0fb7e66fec944ed1c3bfc61307494aff87c2fe24e16479605043a79e0634bc23940d01fc337c6c1
+DIST flacon-8.2.0.tar.gz 3757221 BLAKE2B dff0dc849c326a53ad167efea3106ca2d057121081822a821f2daa4cc2140a858960f1b4cdc2935f3e569aac25c25ceece2d171056788b9f541355c540457550 SHA512 9799c1a27426a2f67d782f15a3a1d210c5dc61b00b30b9c4143047a243f2d46cb0eb651c18919fa1ac2a8fdc2f54c83ec2e0b46a00254c908230e7ffb34965bc
diff --git a/media-sound/flacon/flacon-8.2.0.ebuild b/media-sound/flacon/flacon-8.2.0.ebuild
new file mode 100644
index 000000000000..e9311569dc93
--- /dev/null
+++ b/media-sound/flacon/flacon-8.2.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Tests require lots of disk space
+CHECKREQS_DISK_BUILD=10G
+inherit check-reqs cmake optfeature virtualx xdg-utils
+
+DESCRIPTION="Extracts audio tracks from an audio CD image to separate tracks"
+HOMEPAGE="https://flacon.github.io/"
+SRC_URI="https://github.com/flacon/flacon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+BDEPEND="
+ virtual/pkgconfig
+ dev-qt/linguist-tools:5
+ media-libs/taglib
+"
+RDEPEND="
+ app-i18n/uchardet
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ test? (
+ dev-qt/qttest:5
+ media-libs/flac
+ media-sound/mac
+ media-sound/shntool
+ media-sound/ttaenc
+ media-sound/wavpack
+ )
+"
+
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ use test && check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ use test && check-reqs_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ virtx "${BUILD_DIR}/tests/${PN}_test"
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} optionally supports formats listed below."
+ optfeature 'FLAC input and output support' media-libs/flac
+ optfeature 'WavPack input and output support' media-sound/wavpack
+ optfeature 'APE input support' media-sound/mac
+ optfeature 'TTA input support' media-sound/ttaenc
+ optfeature 'AAC output support' media-libs/faac
+ optfeature 'MP3 output support' media-sound/lame
+ optfeature 'Vorbis output support' media-sound/vorbis-tools
+ optfeature 'MP3 Replay Gain support' media-sound/mp3gain
+ optfeature 'Vorbis Replay Gain support' media-sound/vorbisgain
+
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}