summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-11-04 02:05:57 -0400
committerTim Harder <radhermit@gentoo.org>2016-11-04 02:17:22 -0400
commite478f1f4dce585a538f771567ded9e928e383a6e (patch)
tree666a5985932b46ef5aa4cdfd09eeb661bb9e89b2
parentdev-ruby/twitter-text: add 1.14.1 (diff)
downloadgentoo-e478f1f4.tar.gz
gentoo-e478f1f4.tar.bz2
gentoo-e478f1f4.zip
app-backup/bup: initial import
-rw-r--r--app-backup/bup/Manifest1
-rw-r--r--app-backup/bup/bup-0.28.1.ebuild57
-rw-r--r--app-backup/bup/metadata.xml14
3 files changed, 72 insertions, 0 deletions
diff --git a/app-backup/bup/Manifest b/app-backup/bup/Manifest
new file mode 100644
index 000000000000..5906177ba64b
--- /dev/null
+++ b/app-backup/bup/Manifest
@@ -0,0 +1 @@
+DIST bup-0.28.1.tar.gz 377712 SHA256 fd962dbdade1b8ea257ac0e95d771ba11e6da4ef6f8ca6bee498a5b1bce8c817 SHA512 b27a94eeee86366f9f97081611d8e0443686ed8c4070d45729ad4efe1d48ee9f528d3257bfd5d37d6243927f5b63d6b613bf5ae2c39117012979ccd5ccecf9d2 WHIRLPOOL 5415df9bee662e0ffdcd81fa766c56a2d747df269d78dda0341bf59d607f4d2570bb1d9fdb055d4bc11992a707b8a36b1d9d7f11d0cfd6e504aa501e1cec7ba1
diff --git a/app-backup/bup/bup-0.28.1.ebuild b/app-backup/bup/bup-0.28.1.ebuild
new file mode 100644
index 000000000000..195a4f33eb36
--- /dev/null
+++ b/app-backup/bup/bup-0.28.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="A highly efficient backup system based on the git packfile format"
+HOMEPAGE="https://bup.github.io/ https://github.com/bup/bup"
+SRC_URI="https://github.com/bup/bup/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test web"
+
+RDEPEND="${PYTHON_DEPS}
+ app-arch/par2cmdline
+ dev-python/fuse-python[${PYTHON_USEDEP}]
+ dev-python/pylibacl[${PYTHON_USEDEP}]
+ dev-python/pyxattr[${PYTHON_USEDEP}]
+ web? ( www-servers/tornado[${PYTHON_USEDEP}] )
+ sys-libs/readline:0
+ dev-vcs/git"
+DEPEND="${RDEPEND}
+ test? (
+ dev-lang/perl
+ net-misc/rsync
+ )
+ app-text/pandoc
+"
+
+# unresolved sandbox issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ sed -e "/^CFLAGS :=/s/-O2 -Werror//" \
+ -i Makefile || die
+}
+
+src_configure() {
+ ./configure || die
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr LIBDIR="/usr/$(get_libdir)/bup" DOCDIR="/usr/share/${PF}" install
+ python_fix_shebang "${ED}"
+ python_optimize "${ED}"
+}
diff --git a/app-backup/bup/metadata.xml b/app-backup/bup/metadata.xml
new file mode 100644
index 000000000000..958844441602
--- /dev/null
+++ b/app-backup/bup/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="web">Support browsing backups via a web interface</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">bup/bup</remote-id>
+ </upstream>
+</pkgmetadata>