summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-04-23 23:32:41 +0200
committerAaron Bauman <bman@gentoo.org>2018-04-26 11:30:07 -0400
commite49994467ae77f9d7158ee98cc6af612b83d61f1 (patch)
treee5f887ac00edc5992f746fbfdbebed894f380760
parentmedia-sound/teamspeak-server-bin: Bump to version 3.1.2 (diff)
downloadgentoo-e4999446.tar.gz
gentoo-e4999446.tar.bz2
gentoo-e4999446.zip
x11-libs/libdlo: New package
Closes: https://bugs.gentoo.org/652702 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7844
-rw-r--r--x11-libs/libdlo/Manifest1
-rw-r--r--x11-libs/libdlo/files/disable-testprogram.patch33
-rw-r--r--x11-libs/libdlo/libdlo-0.1.2.ebuild51
-rw-r--r--x11-libs/libdlo/metadata.xml21
4 files changed, 106 insertions, 0 deletions
diff --git a/x11-libs/libdlo/Manifest b/x11-libs/libdlo/Manifest
new file mode 100644
index 000000000000..53df82c59ce8
--- /dev/null
+++ b/x11-libs/libdlo/Manifest
@@ -0,0 +1 @@
+DIST libdlo-0.1.2.tar.gz 476865 BLAKE2B b2391b58046e1f403b7e0d1eb915a46aa17c47e8ad804246f12f3b94f9ffb4dbc811e5d08aac29c2f4196b5d384e7244bddad3193adff5d5e890a7463a503fbb SHA512 6df69bebcf3142e0a87f66bb9d690fd78b96e08c2ae5d46fe0f3d91bc135364d5f5dd0c3a481705c3cd90c78a0a076757220fbcc3b0ad4343cdddb54501e3f2f
diff --git a/x11-libs/libdlo/files/disable-testprogram.patch b/x11-libs/libdlo/files/disable-testprogram.patch
new file mode 100644
index 000000000000..a8f2bba40bf4
--- /dev/null
+++ b/x11-libs/libdlo/files/disable-testprogram.patch
@@ -0,0 +1,33 @@
+--- a/configure.ac 2009-10-19 04:41:33.000000000 +0200
++++ b/configure.ac 2018-04-23 23:18:48.867807771 +0200
+@@ -48,7 +48,6 @@
+
+ AC_CONFIG_FILES([Makefile
+ src/Makefile
+- test/Makefile
+ ])
+ AC_OUTPUT
+ AC_MSG_RESULT([
+--- a/Makefile.am 2009-10-09 02:20:55.000000000 +0200
++++ b/Makefile.am 2018-04-23 23:19:27.036807625 +0200
+@@ -1,19 +1,13 @@
+-SUBDIRS=src \
+- test
++SUBDIRS=src
+ dist_doc_DATA = README
+ ACLOCAL_AMFLAGS = -I m4
+ AUTOMAKE_OPTIONS = foreign
+ EXTRA_DIST = \
+ autogen.sh \
+- test/images/test08.bmp \
+- test/images/test16.bmp \
+- test/images/test24.bmp \
+- test/images/test32.bmp \
+ Guide-v104.pdf \
+ mkdox.sh
+
+ TESTS_ENVIRONMENT = sudo
+-TESTS = test/test1
+
+ MAINTAINERCLEANFILES = depcomp INSTALL install-sh missing aclocal.m4 config.guess config.sub configure
+
diff --git a/x11-libs/libdlo/libdlo-0.1.2.ebuild b/x11-libs/libdlo/libdlo-0.1.2.ebuild
new file mode 100644
index 000000000000..d461b4dee5b7
--- /dev/null
+++ b/x11-libs/libdlo/libdlo-0.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A fully open source driver which supports all DisplayLink devices"
+HOMEPAGE="https://libdlo.freedesktop.org/wiki/"
+SRC_URI="https://people.freedesktop.org/~berniet/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs test-program"
+
+RDEPEND="virtual/libusb:0="
+
+DEPEND="${RDEPEND}"
+
+DOCS=( "AUTHORS" "ChangeLog" "Guide-v104.pdf" "README" )
+
+src_prepare() {
+ default
+
+ # AM_PROG_AR must be defined or automake will fail with:
+ # archiver requires 'AM_PROG_AR' in 'configure.ac'.
+ sed -i -e '/AC_PROG_CC/a AM_PROG_AR' configure.ac || die
+
+ # Only build the Displaylink test program, if a user wants it.
+ if ! use test-program; then
+ eapply "${FILESDIR}"/disable-testprogram.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Rename the Displaylink test program to an useful name
+ if use test-program; then
+ mv "${D}"/usr/bin/test1 "${D}"/usr/bin/displaylink-test || die
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/x11-libs/libdlo/metadata.xml b/x11-libs/libdlo/metadata.xml
new file mode 100644
index 000000000000..c0175f30bba8
--- /dev/null
+++ b/x11-libs/libdlo/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ A fully open source GPL driver which supports all DisplayLink devices
+ in the mainline Linux kernel, called udlfb. It's possible to write
+ custom applications for it or to the libdlo user mode library itself.
+ And it's also possible to configure X and standard X applications to run on udlfb.
+ </longdescription>
+ <use>
+ <flag name="test-program">Build the program for testing Displaylink devices</flag>
+ </use>
+</pkgmetadata>