summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-18 08:17:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-18 08:22:16 +0200
commite4a4f620fd0824025a36c5ecea9bd005352d9d0f (patch)
treedaa85343152d02de29d6bc374e1286bf094d5638
parentdev-python/odfpy: Enable py3.13 (diff)
downloadgentoo-e4a4f620fd0824025a36c5ecea9bd005352d9d0f.tar.gz
gentoo-e4a4f620fd0824025a36c5ecea9bd005352d9d0f.tar.bz2
gentoo-e4a4f620fd0824025a36c5ecea9bd005352d9d0f.zip
dev-python/openapi3: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/openapi3/openapi3-1.8.2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/openapi3/openapi3-1.8.2.ebuild b/dev-python/openapi3/openapi3-1.8.2.ebuild
index 77cb4b50a85a..7a93d407de51 100644
--- a/dev-python/openapi3/openapi3-1.8.2.ebuild
+++ b/dev-python/openapi3/openapi3-1.8.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -26,8 +26,7 @@ RDEPEND="
distutils_enable_tests pytest
-python_test() {
+EPYTEST_IGNORE=(
# the fastapi test is broken for fastapi 0.94+
- rm -f tests/fastapi_test.py || die
- epytest
-}
+ tests/fastapi_test.py
+)