summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-24 12:53:14 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-24 12:53:14 +0100
commite4a995a79fbb6d5bbb2279e358f385975ddf7cd8 (patch)
tree9cc9835788e1990a5d16960e3122b836faeaf88b
parentx11-themes/gtk-engines-aurora: Port to EAPI 7 (diff)
downloadgentoo-e4a995a79fbb6d5bbb2279e358f385975ddf7cd8.tar.gz
gentoo-e4a995a79fbb6d5bbb2279e358f385975ddf7cd8.tar.bz2
gentoo-e4a995a79fbb6d5bbb2279e358f385975ddf7cd8.zip
x11-themes/gtk-engines-candido: Port to EAPI 7
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-glib-2.31.patch4
-rw-r--r--x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild24
2 files changed, 15 insertions, 13 deletions
diff --git a/x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-glib-2.31.patch b/x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-glib-2.31.patch
index d8f7e3e70ff2..68094d31b991 100644
--- a/x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-glib-2.31.patch
+++ b/x11-themes/gtk-engines-candido/files/gtk-engines-candido-0.9.1-glib-2.31.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/412731
---- src/animation.c
-+++ src/animation.c
+--- a/src/animation.c
++++ b/src/animation.c
@@ -7,7 +7,7 @@
#include "animation.h"
diff --git a/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild b/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild
index 74f512f15e49..90d89b19f4f9 100644
--- a/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild
+++ b/x11-themes/gtk-engines-candido/gtk-engines-candido-0.9.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
MY_P="candido-engine-${PV}"
@@ -13,18 +14,17 @@ SRC_URI="mirror://sourceforge/candido.berlios/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.8:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
-DOCS="AUTHORS ChangeLog CREDITS NEWS README"
+PATCHES=( "${FILESDIR}"/${P}-glib-2.31.patch )
src_prepare() {
- epatch "${FILESDIR}"/${P}-glib-2.31.patch
+ default
eautoreconf # required for interix
}
@@ -34,5 +34,7 @@ src_configure() {
src_install() {
default
- find "${ED}" -name '*.la' -exec rm -f {} +
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}