summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 16:17:09 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 16:17:09 +0100
commite4c17b8522686b57636ec9fd26d60141fd4d2662 (patch)
tree1e9b6829230625006763f31b0d5f6b574fe01a99
parentsci-libs/libccd: Disable static libs (diff)
downloadgentoo-e4c17b85.tar.gz
gentoo-e4c17b85.tar.bz2
gentoo-e4c17b85.zip
sci-libs/libccd: Sync live ebuild, fix incorrect EGIT_REPO_URI
Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-libs/libccd/libccd-9999.ebuild14
-rw-r--r--sci-libs/libccd/metadata.xml1
2 files changed, 4 insertions, 11 deletions
diff --git a/sci-libs/libccd/libccd-9999.ebuild b/sci-libs/libccd/libccd-9999.ebuild
index 6f8c7c9f77b5..8c95229c7747 100644
--- a/sci-libs/libccd/libccd-9999.ebuild
+++ b/sci-libs/libccd/libccd-9999.ebuild
@@ -5,9 +5,9 @@ EAPI=7
inherit cmake
-if [ "${PV}" = "9999" ] ; then
+if [[ ${PV} == *9999 ]] ; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/danfis/libccd/${PN}.git"
+ EGIT_REPO_URI="https://github.com/danfis/libccd.git"
else
SRC_URI="https://github.com/danfis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm"
@@ -19,23 +19,17 @@ HOMEPAGE="http://libccd.danfis.cz/
LICENSE="BSD"
SLOT="0"
-IUSE="+double-precision doc +shared test"
+IUSE="+double-precision doc test"
RESTRICT="!test? ( test )"
-RDEPEND=""
-
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )
-"
+BDEPEND="doc? ( dev-python/sphinx )"
src_configure() {
local mycmakeargs=(
-DBUILD_DOCUMENTATION=$(usex doc ON OFF)
- -DBUILD_SHARED_LIBS=$(usex shared ON OFF)
-DENABLE_DOUBLE_PRECISION=$(usex double-precision ON OFF)
)
- local CMAKE_BUILD_TYPE="Release"
cmake_src_configure
}
diff --git a/sci-libs/libccd/metadata.xml b/sci-libs/libccd/metadata.xml
index 62004119dcce..30cf22a0286e 100644
--- a/sci-libs/libccd/metadata.xml
+++ b/sci-libs/libccd/metadata.xml
@@ -11,7 +11,6 @@
implements algorithm Minkowski Portal Refinement (MPR, a.k.a. XenoCollide) as described in Game Programming Gems 7.
</longdescription>
<use>
- <flag name="shared">Build shared library</flag>
<flag name="double">Use double precision floats</flag>
<flag name="double-precision">More precise calculations at the expense of speed</flag>
</use>