summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongsu Park <dpark@linux.microsoft.com>2022-01-27 17:28:09 +0100
committerSam James <sam@gentoo.org>2022-02-18 02:53:32 +0000
commite4c6279825a758f660237211dfcdfd83399887f4 (patch)
tree07ec5554893cd463ac62102c22882169a4fd43f3
parentapp-editors/vim: install defaults.vim only if the file is not installed (diff)
downloadgentoo-e4c6279825a758f660237211dfcdfd83399887f4.tar.gz
gentoo-e4c6279825a758f660237211dfcdfd83399887f4.tar.bz2
gentoo-e4c6279825a758f660237211dfcdfd83399887f4.zip
app-editors/vim-core: skip installing defaults.vim when installed
Do not install defaults.vim when the file is already installed from vim. This is needed for avoiding installation conflicts between vim and vim-core. Closes: https://bugs.gentoo.org/830177 Signed-off-by: Dongsu Park <dpark@linux.microsoft.com> Closes: https://github.com/gentoo/gentoo/pull/23986 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/vim-core/vim-core-8.2.0814.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-8.2.3428.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-8.2.3567.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-8.2.3582.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-8.2.3669.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-8.2.3741.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-8.2.3950.ebuild10
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild10
8 files changed, 56 insertions, 24 deletions
diff --git a/app-editors/vim-core/vim-core-8.2.0814.ebuild b/app-editors/vim-core/vim-core-8.2.0814.ebuild
index 5c1fb6f93cb3..7fd58e8567b7 100644
--- a/app-editors/vim-core/vim-core-8.2.0814.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.0814.ebuild
@@ -191,9 +191,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -208,6 +205,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-8.2.3428.ebuild b/app-editors/vim-core/vim-core-8.2.3428.ebuild
index 40e298a032ae..21bbbbce3423 100644
--- a/app-editors/vim-core/vim-core-8.2.3428.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3428.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-8.2.3567.ebuild b/app-editors/vim-core/vim-core-8.2.3567.ebuild
index a6ac59db33c3..7d7083d927f6 100644
--- a/app-editors/vim-core/vim-core-8.2.3567.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3567.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-8.2.3582.ebuild b/app-editors/vim-core/vim-core-8.2.3582.ebuild
index d04960a41e81..959733ef0bfe 100644
--- a/app-editors/vim-core/vim-core-8.2.3582.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3582.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-8.2.3669.ebuild b/app-editors/vim-core/vim-core-8.2.3669.ebuild
index a6ac59db33c3..7d7083d927f6 100644
--- a/app-editors/vim-core/vim-core-8.2.3669.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3669.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-8.2.3741.ebuild b/app-editors/vim-core/vim-core-8.2.3741.ebuild
index 9ce1dc4f86db..2396c7131d36 100644
--- a/app-editors/vim-core/vim-core-8.2.3741.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3741.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-8.2.3950.ebuild b/app-editors/vim-core/vim-core-8.2.3950.ebuild
index bfac57e4caa8..eda637ba36f0 100644
--- a/app-editors/vim-core/vim-core-8.2.3950.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3950.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index a6ac59db33c3..7d7083d927f6 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it