summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-03 08:46:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-03 09:51:33 +0200
commite507ee8f9e334ff469b3791a5b5377cd9c2754d2 (patch)
tree590a5ff4b3ed9d28c87d363a02f3a70b29db8817
parentdev-python/django-prometheus: Bump to 2.3.1 (diff)
downloadgentoo-e507ee8f9e334ff469b3791a5b5377cd9c2754d2.tar.gz
gentoo-e507ee8f9e334ff469b3791a5b5377cd9c2754d2.tar.bz2
gentoo-e507ee8f9e334ff469b3791a5b5377cd9c2754d2.zip
dev-python/lmfit: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lmfit/Manifest1
-rw-r--r--dev-python/lmfit/lmfit-1.2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/lmfit/Manifest b/dev-python/lmfit/Manifest
index 673c58e56172..76355492d89f 100644
--- a/dev-python/lmfit/Manifest
+++ b/dev-python/lmfit/Manifest
@@ -1,2 +1,3 @@
DIST lmfit-1.2.0.tar.gz 321357 BLAKE2B 2640deb021c87de0b583c0a48fdc6ab3bde1e02f811aeb7a636dc29f8d62b61e17d3f3aef9e2b847a1ada9371a41e4dd50acb8f32495ce69a83db4bcf7c3ba7e SHA512 05110357b43ff15fe0df11e66544f0aea548c4c49ad059fb4da5a1038f1773cf669646c29cdfff8d4e7351caca21953dbbea1a058b0b8ec7310b8b04d5d4d46c
+DIST lmfit-1.2.1.tar.gz 329039 BLAKE2B cac8cfbe56669e28d46e64966b28557162f64591157ca09c2ce9d6206a5dd25890574f80aa4c984121876ee695f8689917a3faa0e94264770dedf1242b22e217 SHA512 221ea62d381ebb41afc173bb79bdd207c4ed6af5f9fb77caa2acc570c59a75bf75f4cf512bb8fb9a33bcad57153d37fec96047b8019e47704690fbe5776282fe
DIST lmfit-py-1.1.0.gh.tar.gz 300406 BLAKE2B b874efd70bc1c5fa2c94239027d636a8dd5bf5ca2a3481cfc467032efe9d57ff55c74ccf175f32c6f87cd285e9216db49ef4fb0566e86cafe85537a40db64366 SHA512 9d5c871446a5bb650d8709b0db100e23be8ed7459ceb7ea4614fb07b1058044bb07394b2af615ecf7d9a22aaf49c1da723cb555749956d1f3ad507a4465fa0da
diff --git a/dev-python/lmfit/lmfit-1.2.1.ebuild b/dev-python/lmfit/lmfit-1.2.1.ebuild
new file mode 100644
index 000000000000..e4083a2df21c
--- /dev/null
+++ b/dev-python/lmfit/lmfit-1.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Non-Linear Least-Squares Minimization and Curve-Fitting for Python"
+HOMEPAGE="
+ https://lmfit.github.io/lmfit-py/
+ https://github.com/lmfit/lmfit-py/
+ https://pypi.org/project/lmfit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asteval-0.9.28[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.19[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.6[${PYTHON_USEDEP}]
+ >=dev-python/uncertainties-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}