summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-04-30 19:18:07 +0200
committerPacho Ramos <pacho@gentoo.org>2020-04-30 19:18:07 +0200
commite50f915e573499a896c6c6b433f12a9768b84132 (patch)
treec3dd424d32c2c450b5d9f55a073f354de5d496f1
parentdev-python/pyclipper: python2 support not needed by revdeps (diff)
downloadgentoo-e50f915e.tar.gz
gentoo-e50f915e.tar.bz2
gentoo-e50f915e.zip
dev-python/setuptools_scm_git_archive: python2 support not needed, fix tests
All reverse deps are ported to python3, fix tests Thanks-to: Agostino Sarubbo Closes: https://bugs.gentoo.org/720064 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
index 0747a0892490..94d423503545 100644
--- a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
inherit distutils-r1
DESCRIPTION="A setuptools_scm plugin for git archives"
@@ -21,11 +21,13 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+distutils_enable_tests pytest
+
src_prepare() {
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
distutils-r1_src_prepare
}
python_test() {
- esetup.py test
+ pytest tests.py || die
}