summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-05-27 16:46:48 +0200
committerAaron Bauman <bman@gentoo.org>2018-05-27 12:22:58 -0400
commite52017c21972caa5edb4dc999902f7b30c9b3a9b (patch)
treed2fa07d097521acf64b5731ad8c08b0a6cba81a1
parentapp-vim/rust-vim: use HTTPs (diff)
downloadgentoo-e52017c2.tar.gz
gentoo-e52017c2.tar.bz2
gentoo-e52017c2.zip
dev-python/rst-linker: bump to 1.10
setup.py requires pytest 3.5 for testing but 3.4 seems to work, so stick to that version for now since 3.5 is not yet in the tree. The whole namespace-package-related logic can be removed since https://github.com/jaraco/rst.linker/commit/c84284022a198d560e685c5a687458a5be4c5fe6 Package-Manager: Portage-2.3.38, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8625
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-1.10.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index 9392617ea7dc..a782e81e4ddd 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1,2 +1,3 @@
+DIST rst.linker-1.10.tar.gz 8820 BLAKE2B 3615353dcce16652aa3528985997467e1501161b012fad44203fd98cc5e91dc32acf6c8492f0797ae748a87c008e5f3437833b435c5cbd85845340b91665e664 SHA512 5541d0ba5299a6efee444ed3c4fb4f108bcdd7c84e4be0b0a44f71c9f13e18d5b5c4c38328a542fe5666d435e1e04c35c0db5535706a45932dc01590813a85cc
DIST rst.linker-1.7.tar.gz 6798 BLAKE2B d4d5129bd79534cbc58f287a60876153325cde3142b3e516e3a75f22827f78c85edbd8eb2777263e6bf3c04f6ebabc78441647df3ed23950982ebd7ebe156632 SHA512 380cd1b36a1153a6512144b7c83be75dfa95ce397437d34cb76c4c41de6266c77cf1f811f4fb0576838e10bd78e1f46394df11b0f7dc5e3fafeef36b6e8c9ba0
DIST rst.linker-1.9.tar.gz 7618 BLAKE2B b344495a217d7cd1c057256701130851975e46c45a740251ce20efa5131feb46a074fb1367a645e89b436b7e093baad1a484d06ca069ebc0f59eca8183ddd36d SHA512 b3e39b025f75bb6ff670f23ee7abd48dcc4e19343626c1ffadd2304a7e3285fe0b7369ace96e47094606e864672c8aeea967a02217b110762e53498dde64b8a7
diff --git a/dev-python/rst-linker/rst-linker-1.10.ebuild b/dev-python/rst-linker/rst-linker-1.10.ebuild
new file mode 100644
index 000000000000..b84ffd335f50
--- /dev/null
+++ b/dev-python/rst-linker/rst-linker-1.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
+HOMEPAGE="https://github.com/jaraco/rst.linker"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/path-py[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Ignore the module from ${S}, use the one from ${BUILD_DIR}
+ # Otherwise, ImportMismatchError may occur
+ # https://github.com/gentoo/gentoo/pull/1622#issuecomment-224482396
+ # Override pytest options to skip flake8
+ py.test -v --ignore=rst --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}