summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-07-11 09:45:16 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-07-11 09:56:19 +0200
commite57a5c17a88e5ed93f126895610725d610c4948b (patch)
tree3b7a28460eb3617c1ad853707d4e5d66b067dad5
parentapp-i18n/canna: ia64 keyworded, bug #624226 (diff)
downloadgentoo-e57a5c17a88e5ed93f126895610725d610c4948b.tar.gz
gentoo-e57a5c17a88e5ed93f126895610725d610c4948b.tar.bz2
gentoo-e57a5c17a88e5ed93f126895610725d610c4948b.zip
www-apps/nikola: add missing die.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--www-apps/nikola/nikola-7.8.8.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/www-apps/nikola/nikola-7.8.8.ebuild b/www-apps/nikola/nikola-7.8.8.ebuild
index 43a622c0fae6..b5dd7d519262 100644
--- a/www-apps/nikola/nikola-7.8.8.ebuild
+++ b/www-apps/nikola/nikola-7.8.8.ebuild
@@ -3,6 +3,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4} ) # 3.5 and 3.6 wait for dependencies
+
inherit distutils-r1
MY_PN="Nikola"
@@ -47,14 +48,14 @@ RDEPEND="${DEPEND}
websocket? ( ~dev-python/ws4py-0.3.4[${PYTHON_USEDEP}] )"
# typography? ( >=dev-python/typogrify-2.0.4[${PYTHON_USEDEP}] ) # needs smartypants
-S="${WORKDIR}"/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_install() {
distutils-r1_src_install
# hackish way to remove docs that ended up in the wrong place
- rm -rf "${D}"/usr/share/doc/${PN}
+ rm -rv "${D}/usr/share/doc/${PN}" || die
dodoc AUTHORS.txt CHANGES.txt README.rst docs/*.txt
- doman docs/man/${PN}.1.gz
+ doman "docs/man/${PN}.1.gz"
}