summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-08-21 17:15:33 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-08-21 17:16:43 +0200
commite597bf5789ebab65a2b4c7c96c7a3ac66bf1a391 (patch)
tree8f377162027eae85df989ce0ebab13f72d756125
parentdev-python/mysqlclient: add dev-python/mock test dep (diff)
downloadgentoo-e597bf5789ebab65a2b4c7c96c7a3ac66bf1a391.tar.gz
gentoo-e597bf5789ebab65a2b4c7c96c7a3ac66bf1a391.tar.bz2
gentoo-e597bf5789ebab65a2b4c7c96c7a3ac66bf1a391.zip
sys-fs/xfsprogs: Bump to version 5.13.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-fs/xfsprogs/Manifest1
-rw-r--r--sys-fs/xfsprogs/xfsprogs-5.13.0.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index 948ff52e7872..525352eed00f 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -1,3 +1,4 @@
DIST xfsprogs-5.10.0.tar.xz 1273332 BLAKE2B 8caaa0ca8a94480f131d36b383afcf732b3a5a7a3c7927b4b4da4855fc5a0fb97a56fcebb98391a4dd0f02465868a4bd857e57eeba053a419df47d42f74bc958 SHA512 da09e687c87c4b133888dba7b4458017ec028020637ea5066be0232bf5c7da18239cc33eadd02d9b99d1c835aab38cab1ec9d45ae8b83897f9157cfcb0271fbd
DIST xfsprogs-5.11.0.tar.xz 1297180 BLAKE2B 0ae0c2eccdf124b9fc2f9a4ef71073324f3645bc9a4f2959978fa06ee4dae4ecaf4eee40e6b130b65eb390d8af0f9d1485aeac073a8ac5e30fce46eef9cdb7a4 SHA512 7a77f938a54176652ce0b53cab13509754aab560c02d74ab03a9fcebf2728d703f89ad9d281ef00fcc0dbabb5497cab2b2b656bbe7598037a16fff70126e5d66
DIST xfsprogs-5.12.0.tar.xz 1299332 BLAKE2B 96e8831ca83d362792853188939017b53343232c99ed514fda50ea9afa828ea8f8ecc753249b211037c2635b45bfbcc849f90fe277102e4745e6b4f13fc6fc20 SHA512 d31263529cd5e0aad2b4414aca91f352c6df9de9a241655e43b5592a3ca120efdcfcd8cf84401ebd1b3fcf67027f0923fecc6f961bdaf12fb00c3ac67abd5fe7
+DIST xfsprogs-5.13.0.tar.xz 1301112 BLAKE2B 49e2b8535ef778362e68d45b1fb6f01be354dbee48d346c018e75ca1a5bc8761f47e65199bb62ffc4962faf8e185f3579e34e0562fab346d9839810727110665 SHA512 8e21bc43fb5cd49dccd6415b86f9e146d29c265a5d908f6898673290d6a2ac4a00bd25440fd7fab5ba080237d4bd54f56855ae64cdb32e59edae100b96155ca8
diff --git a/sys-fs/xfsprogs/xfsprogs-5.13.0.ebuild b/sys-fs/xfsprogs/xfsprogs-5.13.0.ebuild
new file mode 100644
index 000000000000..030c8acbec7d
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-5.13.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs systemd usr-ldscript
+
+DESCRIPTION="xfs filesystem utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="icu libedit nls"
+
+RDEPEND=">=sys-apps/util-linux-2.17.2
+ dev-libs/inih
+ icu? ( dev-libs/icu:= )
+ libedit? ( dev-libs/libedit )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.15.0-docdir.patch
+ "${FILESDIR}"/${PN}-5.3.0-libdir.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix doc dir
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in || die
+
+ # Don't install compressed docs
+ sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
+}
+
+src_configure() {
+ # include/builddefs.in will add FCFLAGS to CFLAGS which will
+ # unnecessarily clutter CFLAGS (and fortran isn't used)
+ unset FCFLAGS
+
+ export DEBUG=-DNDEBUG
+
+ # Package is honoring CFLAGS; No need to use OPTIMIZER anymore.
+ # However, we have to provide an empty value to avoid default
+ # flags.
+ export OPTIMIZER=" "
+
+ unset PLATFORM # if set in user env, this breaks configure
+
+ # Avoid automagic on libdevmapper, #709694
+ export ac_cv_search_dm_task_create=no
+
+ # Build fails with -O3 (bug #712698)
+ replace-flags -O3 -O2
+
+ # Upstream does NOT support --disable-static anymore,
+ # https://www.spinics.net/lists/linux-xfs/msg30185.html
+ # https://www.spinics.net/lists/linux-xfs/msg30272.html
+ local myconf=(
+ --enable-blkid
+ --with-crond-dir="${EPREFIX}/etc/cron.d"
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ $(use_enable icu libicu)
+ $(use_enable nls gettext)
+ $(use_enable libedit editline)
+ )
+
+ if is-flagq -flto ; then
+ myconf+=( --enable-lto )
+ else
+ myconf+=( --disable-lto )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install
+ emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install-dev
+
+ gen_usr_ldscript -a handle
+}