summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2021-05-17 23:06:49 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 10:01:12 +0300
commite5a03a7ad2028405cd1cc8f1fd4001b63b3b68d6 (patch)
tree77036f9841ff271e136a817a9db70f212de5f587
parentx11-terms/zutty: Bump to 0.9 (diff)
downloadgentoo-e5a03a7ad2028405cd1cc8f1fd4001b63b3b68d6.tar.gz
gentoo-e5a03a7ad2028405cd1cc8f1fd4001b63b3b68d6.tar.bz2
gentoo-e5a03a7ad2028405cd1cc8f1fd4001b63b3b68d6.zip
media-sound/whipper: version bump to 0.10.0
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Closes: https://github.com/gentoo/gentoo/pull/20858 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--media-sound/whipper/Manifest1
-rw-r--r--media-sound/whipper/whipper-0.10.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/whipper/Manifest b/media-sound/whipper/Manifest
index ba710ca070b6..09b01a649db2 100644
--- a/media-sound/whipper/Manifest
+++ b/media-sound/whipper/Manifest
@@ -1 +1,2 @@
+DIST whipper-0.10.0.tar.gz 256546 BLAKE2B c673aaefa8fe621e11a1140c2927bb2f62d5b07e94f6cec5b95ba290e5eab215c98b9a59c144b26c71bde211a45d603ba08c477d12b12ed1c73f9f8c2ebdb9a7 SHA512 728ad98185aa2d29f4fb215a597136691bb2c3590b3cac4f659238f90a3b4328c377fafe830a725b655f050538739f404b3eca853db4c39001d1b9d721dc7fd8
DIST whipper-0.9.0.tar.gz 200836 BLAKE2B 197567d476bcfa448bee7d6ba2d1b980355f792e6591840d1291800c3ae205496dc58579394870adf171f11f31d7042b48d070cf03d203e45e7c369500c500ef SHA512 49e66ad2c6e8450199a53a28bb71725704daac86ce2cbf68080d4dee1c2357cf8367ddb4735a07f2ffe612d84f016661e5b6f94efa9d5a7d6b8cf56ee32b0ae7
diff --git a/media-sound/whipper/whipper-0.10.0.ebuild b/media-sound/whipper/whipper-0.10.0.ebuild
new file mode 100644
index 000000000000..964e6c65cd23
--- /dev/null
+++ b/media-sound/whipper/whipper-0.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python CD-DA ripper preferring accuracy over speed (forked from morituri)"
+HOMEPAGE="https://github.com/whipper-team/whipper"
+SRC_URI="https://github.com/whipper-team/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libsndfile:="
+RDEPEND="
+ ${DEPEND}
+ app-cdr/cdrdao
+ >=dev-libs/libcdio-paranoia-0.94_p2
+ >=dev-python/pycdio-2.1.0[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-discid[${PYTHON_USEDEP}]
+ dev-python/python-musicbrainz-ngs[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-libs/mutagen[${PYTHON_USEDEP}]
+ media-sound/sox[flac]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/twisted[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests unittest
+
+PATCHES=( "${FILESDIR}/${PN}-0.7.0-cdparanoia-name-fix.patch" )
+
+python_prepare_all() {
+ # accurip test totally depends on network access
+ rm "${PN}"/test/test_common_accurip.py || die
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+ distutils-r1_python_prepare_all
+}