summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-06 23:21:44 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-09-08 22:39:17 +0200
commite5ba63c4ad25185b193a744a4af3c6cf72f2cbba (patch)
tree988520f5b5c33a00c8b15447ed16b0696ce6e66b
parentsys-apps/smc-sum-driver: use correct kernel for compilation (diff)
downloadgentoo-e5ba63c4ad25185b193a744a4af3c6cf72f2cbba.tar.gz
gentoo-e5ba63c4ad25185b193a744a4af3c6cf72f2cbba.tar.bz2
gentoo-e5ba63c4ad25185b193a744a4af3c6cf72f2cbba.zip
sys-apps/smc-sum-driver: drop old version
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/12878 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r2.ebuild39
-rw-r--r--sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild2
2 files changed, 1 insertions, 40 deletions
diff --git a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r2.ebuild b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r2.ebuild
deleted file mode 100644
index 825bec7d32ea..000000000000
--- a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-mod
-
-MY_DATE="$(ver_cut 4)"
-MY_PN="${PN//-/_}"
-MY_PV="$(ver_cut 1-3)"
-MY_P="${MY_PN/smc_/}_V${MY_PV}"
-
-DESCRIPTION="Supermicro Update Manager (SUM) kernel module"
-HOMEPAGE="https://www.supermicro.com"
-SRC_URI="${MY_P}_${MY_DATE}.tar.gz"
-
-KEYWORDS="-* ~amd64 ~x86"
-LICENSE="supermicro"
-SLOT="0"
-
-RESTRICT="bindist fetch mirror"
-
-S="${WORKDIR}"/${MY_P}/Linux
-
-BUILD_TARGETS="default"
-MODULE_NAMES="sum_bios(misc:${S})"
-
-pkg_nofetch() {
- elog "Please contact the Supermicro support at support@supermicro.com,"
- elog "in order to obtain a copy of ${A}"
- elog "and place it in your DISTDIR directory."
-}
-
-src_prepare() {
- # Install new Makefile to respect users CFLAGS and LDFLAGS
- cp "${FILESDIR}"/makefile Makefile
-
- default
-}
diff --git a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild
index d9f03bc988ec..c8dba118df71 100644
--- a/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild
+++ b/sys-apps/smc-sum-driver/smc-sum-driver-1.6.0.20151201-r3.ebuild
@@ -35,7 +35,7 @@ src_prepare() {
default
# Install new Makefile to respect users CFLAGS and LDFLAGS
- cp "${FILESDIR}"/makefile Makefile
+ cp "${FILESDIR}"/makefile Makefile || die
}
src_compile() {