summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-07-24 23:56:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-07-24 23:57:03 -0500
commite5bd088444fd7f00f961fb5214f22818c7369e79 (patch)
tree6864c7dc568f375c106c320a8c84e66ee9cf7dc0
parentdev-db/redis: drop 6.2.12, 7.0.11 (diff)
downloadgentoo-e5bd0884.tar.gz
gentoo-e5bd0884.tar.bz2
gentoo-e5bd0884.zip
gui-apps/wl-clipboard: 2.2.0 bump
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--gui-apps/wl-clipboard/Manifest1
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-2.2.0.ebuild27
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-9999.ebuild6
3 files changed, 32 insertions, 2 deletions
diff --git a/gui-apps/wl-clipboard/Manifest b/gui-apps/wl-clipboard/Manifest
index c41533df8f00..11f5c5d11c36 100644
--- a/gui-apps/wl-clipboard/Manifest
+++ b/gui-apps/wl-clipboard/Manifest
@@ -1 +1,2 @@
DIST wl-clipboard-2.1.0.tar.gz 43198 BLAKE2B 02d203072d51a412945f125fb9653391342548ce4bd5688f96310d50006824017fb1bde728a15d2c20d22e90f47af7dbb1e858ff7d8f1df6596794a0b5479d43 SHA512 3edcbec2df3a3d7f88ea9271f3befee61b888b4be4f1be6ca238958d78436a445ffd5a84d20ff4eaf4835016696c8e3f14df7b48c391b0647416e9eb9cbf5d2e
+DIST wl-clipboard-2.2.0.tar.gz 49344 BLAKE2B 4d7c8e5756396748871dd54f8823857511e0666b6bb5efa783894660efaf533a99064b84456439390f2ff2fc2fe16d97748efcafe24cfa18dbced42fb82e0269 SHA512 a2667b26970ebdd4c6d8bb6a05d902fa446fb94ba2c878dfa896e502277dac9837c75370108de9a39308597c153f3952289933174adf535148d027593a6cf829
diff --git a/gui-apps/wl-clipboard/wl-clipboard-2.2.0.ebuild b/gui-apps/wl-clipboard/wl-clipboard-2.2.0.ebuild
new file mode 100644
index 000000000000..7e7fdd6a0b37
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ dev-libs/wayland-protocols"
diff --git a/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
index 30f120a0c50a..7e7fdd6a0b37 100644
--- a/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
+++ b/gui-apps/wl-clipboard/wl-clipboard-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2022 Gentoo Authors
+# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,4 +22,6 @@ IUSE=""
DEPEND="dev-libs/wayland"
RDEPEND="${DEPEND}"
-BDEPEND="dev-util/wayland-scanner"
+BDEPEND="
+ dev-util/wayland-scanner
+ dev-libs/wayland-protocols"