summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-17 02:16:22 +0100
committerSam James <sam@gentoo.org>2021-10-17 02:18:48 +0100
commite5c3015103d03d843ae488d7fdaea4a4a5757374 (patch)
tree68cfa0920a4551d3a1a27bc4b66268a0d413dee2
parentdev-lang/fpc: add (~)arm64 support to 3.2.2 (diff)
downloadgentoo-e5c30151.tar.gz
gentoo-e5c30151.tar.bz2
gentoo-e5c30151.zip
sci-libs/gdal: fix automagic libheif
Closes: https://bugs.gentoo.org/818514 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--profiles/arch/ia64/package.use.mask4
-rw-r--r--profiles/arch/powerpc/ppc32/package.use.mask4
-rw-r--r--sci-libs/gdal/gdal-3.3.2-r1.ebuild (renamed from sci-libs/gdal/gdal-3.3.2.ebuild)4
-rw-r--r--sci-libs/gdal/metadata.xml1
4 files changed, 12 insertions, 1 deletions
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index 1905e7a6b62a..639176a9f265 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2021-10-17)
+# media-libs/libheif not keyworded here
+sci-libs/gdal heif
+
# Sam James <sam@gentoo.org> (2021-09-14)
# JACK2 isn't keyworded here
# bug #807616
diff --git a/profiles/arch/powerpc/ppc32/package.use.mask b/profiles/arch/powerpc/ppc32/package.use.mask
index 0abe138ca7af..637b5a7129af 100644
--- a/profiles/arch/powerpc/ppc32/package.use.mask
+++ b/profiles/arch/powerpc/ppc32/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Sam James <sam@gentoo.org> (2021-10-17)
+# media-libs/libheif not keyworded here
+sci-libs/gdal heif
+
# Marek Szuba <marecki@gentoo.org> (2021-08-11)
# dev-ruby/tty-editor not keyworded here yet (Bug #807685)
app-text/htmltidy test
diff --git a/sci-libs/gdal/gdal-3.3.2.ebuild b/sci-libs/gdal/gdal-3.3.2-r1.ebuild
index 216917c266d1..79fe99d64ed3 100644
--- a/sci-libs/gdal/gdal-3.3.2.ebuild
+++ b/sci-libs/gdal/gdal-3.3.2-r1.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://download.osgeo.org/${PN}/${PV}/${P}.tar.gz"
SLOT="0/3.3"
LICENSE="BSD Info-ZIP MIT"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="armadillo +aux-xml curl cpu_flags_x86_avx cpu_flags_x86_sse cpu_flags_x86_ssse3 debug doc fits geos gif gml hdf5 java jpeg jpeg2k lzma mdb mysql netcdf odbc ogdi opencl oracle pdf perl png postgres python spatialite sqlite threads webp xls zstd"
+IUSE="armadillo +aux-xml curl cpu_flags_x86_avx cpu_flags_x86_sse cpu_flags_x86_ssse3 debug doc fits geos gif gml hdf5 heif java jpeg jpeg2k lzma mdb mysql netcdf odbc ogdi opencl oracle pdf perl png postgres python spatialite sqlite threads webp xls zstd"
REQUIRED_USE="
mdb? ( java )
@@ -53,6 +53,7 @@ DEPEND="
geos? ( >=sci-libs/geos-3.8.0 )
gif? ( media-libs/giflib:= )
gml? ( >=dev-libs/xerces-c-3.1 )
+ heif? ( media-libs/libheif:= )
hdf5? ( >=sci-libs/hdf5-1.6.4:=[szip] )
jpeg? ( virtual/jpeg:0= )
jpeg2k? ( media-libs/openjpeg:2= )
@@ -190,6 +191,7 @@ src_configure() {
$(use_with geos)
$(use_with gif)
$(use_with gml xerces)
+ $(use_with heif)
$(use_with hdf5)
$(use_with jpeg pcidsk) # pcidsk is internal, because there is no such library released developer by gdal
$(use_with jpeg)
diff --git a/sci-libs/gdal/metadata.xml b/sci-libs/gdal/metadata.xml
index f505485ec713..ba24c3b77d31 100644
--- a/sci-libs/gdal/metadata.xml
+++ b/sci-libs/gdal/metadata.xml
@@ -19,6 +19,7 @@
<flag name="fits">Enable support for NASA's <pkg>sci-libs/cfitsio</pkg> library</flag>
<flag name="geos">Add support for geometry engine (<pkg>sci-libs/geos</pkg>)</flag>
<flag name="gml">Enable support for <pkg>dev-libs/xerces-c</pkg> C++ API</flag>
+ <flag name="heif">Enable support for ISO/IEC 23008-12:2017 HEIF/HEIC image format using <pkg>media-libs/libheif</pkg></flag>
<flag name="mdb">Enable support for Microsoft Access database</flag>
<flag name="ogdi">Enable support for the open geographic datastore interface (<pkg>sci-libs/ogdi</pkg>)</flag>
<flag name="opencl">Enable OpenCL support</flag>