summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-02-18 14:34:48 +0100
committerUlrich Müller <ulm@gentoo.org>2017-02-18 14:35:32 +0100
commite5cb0314b08eec74ef3c7a3d08891d05b432ed2f (patch)
tree5576fbba3fa7c132d5d2ca11ca08e0a255cef729
parentdev-ml/pomap: amd64 stable wrt bug #607050 (diff)
downloadgentoo-e5cb0314b08eec74ef3c7a3d08891d05b432ed2f.tar.gz
gentoo-e5cb0314b08eec74ef3c7a3d08891d05b432ed2f.tar.bz2
gentoo-e5cb0314b08eec74ef3c7a3d08891d05b432ed2f.zip
app-emacs/navi2ch: EAPI bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--app-emacs/navi2ch/navi2ch-1.8.4-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/navi2ch/navi2ch-1.8.4-r1.ebuild b/app-emacs/navi2ch/navi2ch-1.8.4-r1.ebuild
new file mode 100644
index 000000000000..9c439c5ba72f
--- /dev/null
+++ b/app-emacs/navi2ch/navi2ch-1.8.4-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="A navigator for the Japanese textboard 2ch"
+HOMEPAGE="http://navi2ch.sourceforge.net/"
+SRC_URI="mirror://sourceforge/navi2ch/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ econf \
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
+ --with-icondir="${EPREFIX}${SITEETC}/${PN}"
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ elisp-install ${PN} contrib/*.el
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog* NEWS README TODO
+ newdoc contrib/README README.contrib
+
+ DOC_CONTENTS="Please add the following lines to your ~/.emacs file:
+ \n\nIf you use mona-font:
+ \n\t(setq navi2ch-mona-enable t)
+ \nIf you use izonmoji-mode:
+ \n\t(require 'izonmoji-mode)
+ \n\t(add-hook 'navi2ch-bm-mode-hook 'izonmoji-mode-on)
+ \n\t(add-hook 'navi2ch-article-mode-hook 'izonmoji-mode-on)
+ \n\t(add-hook 'navi2ch-popup-article-mode-hook 'izonmoji-mode-on)"
+ readme.gentoo_create_doc
+}