summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-28 23:01:09 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-28 23:01:34 +0000
commite5e9c00d11e91c95679caa0325f4b205774f3637 (patch)
tree6633b3878c598f4ccb832e2b5419db4387e2659e
parentapp-office/libreoffice: Require cairo with xlib acceleration because of bug 4... (diff)
downloadgentoo-e5e9c00d.tar.gz
gentoo-e5e9c00d.tar.bz2
gentoo-e5e9c00d.zip
sys-libs/libedit: Add libedit to the tree.
libedit is a port of the NetBSD editline library. Package-Manager: portage-2.2.26
-rw-r--r--sys-libs/libedit/Manifest1
-rw-r--r--sys-libs/libedit/libedit-3.1_p20150325.ebuild57
-rw-r--r--sys-libs/libedit/metadata.xml12
3 files changed, 70 insertions, 0 deletions
diff --git a/sys-libs/libedit/Manifest b/sys-libs/libedit/Manifest
new file mode 100644
index 000000000000..f37982b3f095
--- /dev/null
+++ b/sys-libs/libedit/Manifest
@@ -0,0 +1 @@
+DIST libedit-20150325-3.1.tar.gz 502792 SHA256 c88a5e4af83c5f40dda8455886ac98923a9c33125699742603a88a0253fcc8c5 SHA512 03221f3de844a7768764b3ebf80bc3110a13699f452609ba351c134e4225fc7d9e826522c672e925a7f6183094b3f3dbf489f197ddd44e6b1ea5fed762aed07d WHIRLPOOL 19b50ac19c02d852e7fde10896d8e092e305ebd1066903c6a5a9be9792a56f55a5ffc1bebb80bcedacc22b9d9035944bc0ff94ca28173ad6ccc2e97c5754ec81
diff --git a/sys-libs/libedit/libedit-3.1_p20150325.ebuild b/sys-libs/libedit/libedit-3.1_p20150325.ebuild
new file mode 100644
index 000000000000..65f0be97b11e
--- /dev/null
+++ b/sys-libs/libedit/libedit-3.1_p20150325.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils autotools-multilib
+
+DATE="${PV##*_p}"
+MY_PV="${PV%%_*}"
+MY_P="${PN}-${DATE}-${MY_PV}"
+
+DESCRIPTION="Port of the NetBSD editline library"
+HOMEPAGE="http://thrysoee.dk/editline"
+SRC_URI="http://thrysoee.dk/editline/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ sys-libs/ncurses:0="
+
+DEPEND="
+ ${RDEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-widec
+ $(use_enable examples)
+ )
+
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-multilib_src_compile
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}"
+}
+
+src_install() {
+ autotools-multilib_src_install
+}
diff --git a/sys-libs/libedit/metadata.xml b/sys-libs/libedit/metadata.xml
new file mode 100644
index 000000000000..5a0912cce6fe
--- /dev/null
+++ b/sys-libs/libedit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+</pkgmetadata>