summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-29 14:16:09 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-29 14:32:13 -0500
commite5fb79a92fe0bc1dd4a7b38db2ee19383584e66b (patch)
treec96946a01626ec4d44346f67d08f0d96488a991f
parentsys-apps/newrelic-sysmond: remove newrelic-sysmond-1.1.2.124-r1 (diff)
downloadgentoo-e5fb79a9.tar.gz
gentoo-e5fb79a9.tar.bz2
gentoo-e5fb79a9.zip
sys-power/cpudyn: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/573846 Package-Manager: portage-2.2.26
-rw-r--r--sys-power/cpudyn/cpudyn-1.0.1-r2.ebuild49
-rw-r--r--sys-power/cpudyn/files/cpudyn.init4
2 files changed, 51 insertions, 2 deletions
diff --git a/sys-power/cpudyn/cpudyn-1.0.1-r2.ebuild b/sys-power/cpudyn/cpudyn-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..e01be7e17a7f
--- /dev/null
+++ b/sys-power/cpudyn/cpudyn-1.0.1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
+HOMEPAGE="http://freecode.com/projects/cpudyn/"
+SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.99.0-init_conf_updates.patch"
+)
+
+src_prepare() {
+ # fix #570082 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)" cpudynd
+}
+
+src_install() {
+ dosbin cpudynd
+
+ doman cpudynd.8
+ dodoc INSTALL README VERSION changelog
+ docinto html
+ dodoc *.html
+
+ newinitd "${FILESDIR}"/cpudyn.init cpudyn
+ newconfd debian/cpudyn.conf cpudyn
+}
+
+pkg_postinst() {
+ einfo "Configuration file is /etc/conf.d/cpudyn."
+}
diff --git a/sys-power/cpudyn/files/cpudyn.init b/sys-power/cpudyn/files/cpudyn.init
index 877f51f41b7c..11e82db75f19 100644
--- a/sys-power/cpudyn/files/cpudyn.init
+++ b/sys-power/cpudyn/files/cpudyn.init
@@ -1,5 +1,5 @@
-#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
#