summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-03 17:58:48 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-03 21:29:57 +0100
commite62471f21088e072bf84f4a439733be3ad853704 (patch)
treed216348306684444637a4672990bc2b69a259bc2
parentgames-emulation/ppsspp: drop old 1.14.3 (diff)
downloadgentoo-e62471f21088e072bf84f4a439733be3ad853704.tar.gz
gentoo-e62471f21088e072bf84f4a439733be3ad853704.tar.bz2
gentoo-e62471f21088e072bf84f4a439733be3ad853704.zip
games-emulation/ppsspp: bump to 1.14.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--games-emulation/ppsspp/Manifest1
-rw-r--r--games-emulation/ppsspp/ppsspp-1.14.4.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/games-emulation/ppsspp/Manifest b/games-emulation/ppsspp/Manifest
index aedbad47288f..78744c0bc199 100644
--- a/games-emulation/ppsspp/Manifest
+++ b/games-emulation/ppsspp/Manifest
@@ -1,2 +1,3 @@
DIST ppsspp-1.14.1.tar.xz 46414036 BLAKE2B c0076550aea53a878e199c5767bab005df266436d0dc7acb1dc00537c4709854287202f8c5525871c93b103a59406d03b19481a644f9d5985f83d8703659d457 SHA512 b33e43e14eafeea54d40f4f0d332d4f683b80ef6dace66e6101199e7141829b7858c7f94d5a4696393022c0453fcd7ce77858279a31b2ffba5bfcaa72e675b18
DIST ppsspp-1.14.2.tar.xz 46414560 BLAKE2B 3b1cc4a1f7824be4fe0e9abaf52df333965a9b2000bb412b71ea8308a75d4f250ff80c8097856720eb6339926e0b73bb725844f6cabeededc0c2475342a003a9 SHA512 767345235faa54c6a0c19c41fead43f67c39d7f84cd3d573523a745cd082166910090789a985873be047ecaf17513ef318362041f5dcc2b068b1ff061d787f79
+DIST ppsspp-1.14.4.tar.xz 46405556 BLAKE2B 6ba958e8bcefffeeb0d05f3c14cf7381737a02deed27c45d564ba4e556af5654e51ffad5c8a8f880ce85b8916db4ed51b8be13c1ca01f7b6d7b28fa266425605 SHA512 144f5af637f747c745a34d28c95d498cfc736777240ad4eb0a08721af2fcb36106cf93a73d49df0fb572ee7ec78b4bc0965c9f4b3845e9457a4d7c967b8389ec
diff --git a/games-emulation/ppsspp/ppsspp-1.14.4.ebuild b/games-emulation/ppsspp/ppsspp-1.14.4.ebuild
new file mode 100644
index 000000000000..68d009557eee
--- /dev/null
+++ b/games-emulation/ppsspp/ppsspp-1.14.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-any-r1 xdg cmake
+
+DESCRIPTION="A PSP emulator written in C++"
+HOMEPAGE="https://www.ppsspp.org/
+ https://github.com/hrydgard/ppsspp/"
+SRC_URI="https://github.com/hrydgard/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 JSON MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="discord qt5"
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/snappy:=
+ app-arch/zstd:=
+ dev-libs/libzip:=
+ dev-util/glslang:=
+ media-libs/glew:=
+ media-libs/libpng:=
+ media-libs/libsdl2[joystick]
+ media-video/ffmpeg:0/56.58.58
+ sys-libs/zlib:=
+ virtual/opengl
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtmultimedia:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ !qt5? ( media-libs/libsdl2[X,opengl,sound,video] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-CMakeLists-flags.patch
+ "${FILESDIR}"/${PN}-disable-ccache-autodetection.patch
+)
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_SKIP_RPATH=ON
+ -DHEADLESS=false
+ -DUSE_DISCORD=$(usex discord)
+ -DUSE_SYSTEM_FFMPEG=ON
+ -DUSE_SYSTEM_LIBZIP=ON
+ -DUSE_SYSTEM_SNAPPY=ON
+ -DUSE_SYSTEM_ZSTD=ON
+ -DUSING_QT_UI=$(usex qt5)
+ )
+ cmake_src_configure
+}