summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-01 08:46:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-01 09:32:09 +0100
commite658e9c761827c31ef5f6b96ad914dbc579f5988 (patch)
tree3b4e98a5dfb6862e33bdec2a129c52bac1fad76c
parentdev-python/pydevd: Bump to 2.7.0 (diff)
downloadgentoo-e658e9c7.tar.gz
gentoo-e658e9c7.tar.bz2
gentoo-e658e9c7.zip
dev-python/moto: Bump to 2.2.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-2.2.12.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index aca4e5146dcd..a90102e8b2df 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -3,6 +3,7 @@ DIST moto-2.0.5.tar.gz 1551415 BLAKE2B 452cb94443188e1715145bee574f04924d894a3d6
DIST moto-2.2.0.tar.gz 1650655 BLAKE2B 9969de2fb323b2deb272eb47727884054a35827a5db382f83a4177cf6cac5339f89164d05c288a977bc1895a204d13d02069e8b37880ea3d04374f6ed4d6be47 SHA512 7eabb515f94920af9b8f028afaaa51e27983f7bfd73f66c29fc191e2f3dd3e8939ddac67de0127c67c35cbc17c3500a7390103b26c85056780c865aadeb5e1d9
DIST moto-2.2.10.tar.gz 1894714 BLAKE2B aa1298ed0f067406db3fa4bee8246d8611b867ddd353e8cc80e2e961ebb3f2251f46fbe88b011e8064ef397c9a01b66bd5bf8f57ba915a53d6a939f0f3bc6fde SHA512 57c3c3660fa98bcab5a42c1b853ff73a4c00708f2342e3be57a2c099d7947100836dc15c2dd1aff9388149edf1fb54e8173457f89cfecf93957edb0f056f46b5
DIST moto-2.2.11.tar.gz 1914270 BLAKE2B a216cb074ecba0d20c8a82c55726d7f936a780fa40ded2ccbc1f0eddd29d1f6c42a3e1da656008ffb0e2f6b14600145577946f4b2e800df12d71f775c073578c SHA512 e9226f8c585b66a5bb283605ba3a78a8778f4866c487d8090dcb97091b37532c7314c627832b9e2549741f07685224b62c3ce89dcb3dfa18f0bb5df40e80e024
+DIST moto-2.2.12.tar.gz 1941427 BLAKE2B d1f85e46f4072b0e1c48e727d9e99eec12001a5397e738a5ab2e776c59e273a887c72dc5e5fdf2e6b61028f4eddb4b6fa809288bf7b087502192139eae170127 SHA512 a55e96bfe1f1c4a4523be30040350fc2929fb4385a62cc5a96a8fb34febed54d442be0e169f836f813e956c9e388fce8b9c405c59ad023011f9c7c76362c3729
DIST moto-2.2.2.tar.gz 1684678 BLAKE2B ebe1eb08c67ccdb8c484fa8fc75d7ce58750d94620f46b53268d6b6b0732d90160bf7b6837efa492f621e1c001d933f5d59d39c266d65bbb1852f315b3bc03d0 SHA512 a8b192637b701eda0e4a7b11e84f5251386de98590f1d7c33732d8bf12642b39b61f1d360ad39c3e1b0a645268139d9e330d48fbe7029b943094ad317cb45ff6
DIST moto-2.2.3.tar.gz 1700636 BLAKE2B 926fe245ce457dd79eef6780fc0b984d2ff1cbe95807a3463f0d0080583af2ba356ccfcce22e60927737e1531ec7bc167c5f649e784b191ec821aa56df65277d SHA512 0b46229ae06db7cb2634df3f1b3b1a6b6fc983978a763e8879db0d9e209ccc6b96b28e8e2ee40f6e1a8e39b74d7a2430788126220e3a7dab5e8df217c3c8c005
DIST moto-2.2.4.tar.gz 1724663 BLAKE2B 3feb39bec246a8157aa542c711289ab0ca257ec510835cd48aa732c3f07903db857971e3d024c1aef35b5a0b55b7c4ecef2b319824c1d76f0076ab8d2d75329e SHA512 8acd8a3156db71af35ad0ac6a5105a6b7739d8ca9881a2cb091637830bc6fbb10d8bf6adfd1a1091556f9269fad737b345d2bdf50e09b54201fe7438674dd906
diff --git a/dev-python/moto/moto-2.2.12.ebuild b/dev-python/moto/moto-2.2.12.ebuild
new file mode 100644
index 000000000000..90b1a6e1227e
--- /dev/null
+++ b/dev-python/moto/moto-2.2.12.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-tempfile[${PYTHON_USEDEP}]' python3_{6,7})
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/boto3-1.9.201[${PYTHON_USEDEP}]
+ >=dev-python/botocore-1.12.201[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unpin indirect dep on ecdsa that's supposed to workaround pip bugs
+ sed -i -e '/ecdsa/s:<0.15::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}