summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-13 07:01:45 +0000
committerSam James <sam@gentoo.org>2020-09-13 07:01:45 +0000
commite65a8cdfe91cb334bbab25f7d9a06f45c8e198dd (patch)
treededbc65a1063ad42a8d6f25cb547c820ac356b27
parentdev-python/iniconfig: Keyword 1.0.0 ppc, #734780 (diff)
downloadgentoo-e65a8cdf.tar.gz
gentoo-e65a8cdf.tar.bz2
gentoo-e65a8cdf.zip
dev-python/executing: strip wheel dep, add others
Needed dev-python/{setuptools_scm, toml}. Closes: https://bugs.gentoo.org/741747 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/executing/executing-0.5.2.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/executing/executing-0.5.2.ebuild b/dev-python/executing/executing-0.5.2.ebuild
index 0f05179cc812..ca2d34b87107 100644
--- a/dev-python/executing/executing-0.5.2.ebuild
+++ b/dev-python/executing/executing-0.5.2.ebuild
@@ -20,6 +20,8 @@ KEYWORDS="~amd64 ~x86"
# asttokens is optional runtime dep
BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
test? (
dev-python/asttokens[${PYTHON_USEDEP}]
)"
@@ -28,6 +30,13 @@ distutils_enable_tests pytest
export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+src_prepare() {
+ # Kill off useless wheel dep
+ sed -i -e 's/wheel; //' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
python_test() {
# this test explodes when collected by pytest
"${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"