summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-14 11:32:42 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-14 11:32:42 +0100
commite663361d7ae19193db23fcde2d65479fb0409fc8 (patch)
treee39ae12404dd5a7c5331bd60cd8218bc0809a3ea
parentapp-text/crm114: Port to EAPI 7 (diff)
downloadgentoo-e663361d7ae19193db23fcde2d65479fb0409fc8.tar.gz
gentoo-e663361d7ae19193db23fcde2d65479fb0409fc8.tar.bz2
gentoo-e663361d7ae19193db23fcde2d65479fb0409fc8.zip
games-fps/qudos: Apply gcc-10 workaround
* Dead upstream Closes: https://bugs.gentoo.org/708036 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--games-fps/qudos/qudos-0.40.1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/games-fps/qudos/qudos-0.40.1.ebuild b/games-fps/qudos/qudos-0.40.1.ebuild
index 27988248d7dd..1c167f70ec4d 100644
--- a/games-fps/qudos/qudos-0.40.1.ebuild
+++ b/games-fps/qudos/qudos-0.40.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils toolchain-funcs games
+
+inherit eutils flag-o-matic toolchain-funcs games
FILE_STEM="QuDos-${PV}-src"
PK3_FILE="QuDos-${PV}.pk3"
@@ -108,6 +109,11 @@ src_prepare() {
"${FILESDIR}"/${P}-gnusource.patch
}
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
src_compile() {
yesno() { usex $1 YES NO; }