summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-06-04 11:41:47 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-06-04 11:41:47 +0200
commite66751674fba6abf1926db5a1fec6e75cdb8b2fe (patch)
treeebb11e65287ea93d8843f550ac7628d4d59fc1ea
parentsec-policy/selinux-base-policy: Add systemd useflag and module (diff)
downloadgentoo-e66751674fba6abf1926db5a1fec6e75cdb8b2fe.tar.gz
gentoo-e66751674fba6abf1926db5a1fec6e75cdb8b2fe.tar.bz2
gentoo-e66751674fba6abf1926db5a1fec6e75cdb8b2fe.zip
x11-misc/xkeyboard-config: Version bump
Also block incompatible libX11 and xkbcomp instead of depending on them. Bug: https://bugs.gentoo.org/show_bug.cgi?id=583184 Bug: https://bugs.gentoo.org/show_bug.cgi?id=584958 Package-Manager: portage-2.2.28
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.18.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index a3bfb328631f..1c272050d880 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1,3 +1,4 @@
DIST xkeyboard-config-2.14.tar.bz2 953589 SHA256 dc91458a214c56a35727f9e523fc647615de64137057ca6ee4d4d4474a4bb2ae SHA512 b8c9affafcc61fde32bb90fa83c2e5a05a0903a9ec71ee8878a460b6173c82c5d5c95d3735d1e0f65bcdbcd66842788275523ab5f6e78c2e56266cee0d74da58 WHIRLPOOL c3ca9816b0eac131c7556da0f42987b4fd77d4565a92103b2bda0d5b9264893f9e61d2756e231bb9bac353397a310fe5a0415536496b8758e89545676f33741e
DIST xkeyboard-config-2.16.tar.bz2 968663 SHA256 1e8a1f212c96b7f71ca0b05da361cac1816d27baae1d8e03e7b53049b58d1d58 SHA512 7a661d8601a2653b3e2b55b47b3cf02aa1b028d97ea141cab3a234d61fdd00ab6f37d236c38bb96e32c2f0db535975583e17f080f24ac758982c301105d28079 WHIRLPOOL 790b234169b096e927d0ef2f47823e3aa660c24b857d70d8b229d65f7670a8c168ff138904537e019f40405f00dc2361828720457dfd36b1b206244ce5640299
DIST xkeyboard-config-2.17.tar.bz2 973675 SHA256 dec6be44bd31775cdc1ab95bfd75d5f2c0055613eeca8b4e9c6480b183430701 SHA512 375a38fde9befef0c779b7593c17e3889abf5cf73c66e9ff37f58ea65ca6065bad2835a4187321b88187a1922e47ae086663851906c6082860da8096c7e828b1 WHIRLPOOL 6e9187a4fae546af6fc7707a100fbeea22980cb8ae1217e57263c02ef1d79a1f19e5d163f90a3ecb3a5cb0c9e2a3c5aa981e2fb86b51af876297d748127a4761
+DIST xkeyboard-config-2.18.tar.bz2 978557 SHA256 c41d917d6c8a59feb7ccbda51c40a6ada824fdd1e9684b52dd48c9530617ddd0 SHA512 5415fadf66a8e2b671029f4d1cd6726a522d347abe87a0f4f33fa85662dd2dc2348fc7402c53281ad2a8615c61eb447760d16d7dac426df19d0834d05b81f548 WHIRLPOOL 6b0e05f606ee7f41ee1ae7ed90d28a3b7ae973583177fe5b347c72ac2faa210aa25063bc70157168b2b38aa357559f2ff95f8242bcf36b8118fb067fa624fc60
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.18.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.18.ebuild
new file mode 100644
index 000000000000..b3638f191ff5
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.18.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="!<x11-apps/xkbcomp-1.2.3
+ !<x11-libs/libX11-1.4.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=x11-proto/xproto-7.0.20"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}
+
+src_compile() {
+ # cleanup to make sure .dir files are regenerated
+ # bug #328455 c#26
+ xorg-2_src_compile clean
+ xorg-2_src_compile
+}