summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-17 16:24:19 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-17 16:57:39 +0000
commite6a22f2a37bd2acc361382b0704c053057cd2365 (patch)
treecb8f308ed3ebce0de2619c43ebda4cc50854cdc2
parentapp-misc/tdfsb: bump to EAPI4, add missing dependencies (bug #514836), fix fo... (diff)
downloadgentoo-e6a22f2a37bd2acc361382b0704c053057cd2365.tar.gz
gentoo-e6a22f2a37bd2acc361382b0704c053057cd2365.tar.bz2
gentoo-e6a22f2a37bd2acc361382b0704c053057cd2365.zip
dev-java/jansi: Version bump. Fixes bug 472318.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-java/jansi/Manifest1
-rw-r--r--dev-java/jansi/files/jansi-1.5-build.xml251
-rw-r--r--dev-java/jansi/jansi-1.5.ebuild50
3 files changed, 302 insertions, 0 deletions
diff --git a/dev-java/jansi/Manifest b/dev-java/jansi/Manifest
index be073ec56bce..cb067a4ddfc3 100644
--- a/dev-java/jansi/Manifest
+++ b/dev-java/jansi/Manifest
@@ -1,2 +1,3 @@
DIST jansi-1.1-sources.jar 18401 SHA256 c347970cb7e74832ddc7a37966ec9e1697965200eaaadcf4f1f3f407ad965ce4 SHA512 6f731c3e87b3662ce03a951bea837aa02822cb21ad477e458f8a6ce11b6943fba88d5b6c3786bf47fb9e48d4d30debb4527812fa6c58fe973244ace459b6031d WHIRLPOOL 532adaac74483967079676569c446cfe903a7b22dabffddd4be69dac0c7c4c45ea9bad21fcd5658f5768be68650fe971773a549bcbb6973768a0cd912ba00329
DIST jansi-1.11.tar.gz 252095 SHA256 e5c7bd4d9ccba7a2f191380111960c7bd699a7ffee370891b2ef7f905047cccf SHA512 4a19d52055da3ce08b6d797fb8e8241af86f1b9b30e12f4de24655edbd72d256b310d58fc6e106cae1384f9b0ab99cd7f2128d53296875fba5422bfc0e8410f1 WHIRLPOOL 30bc2f3bcf1f74ed5b939e9cfb2c16e54f41e679a97c9983643207b264ddd8fdaf9a898c188f12ea2e84742c45942946f59dda97de1b76f39da050329ef91c24
+DIST jansi-1.5.zip 211616 SHA256 e904c8197f100d91c84207e0ec97aa7d197ea8c916d3aa668526b2d4d0279773 SHA512 784c01b7ab48307cf881439d5c3531949a6459e8a90667f1ee7a73f9cbce72710fcf4af8b4cae610d15085641567c0d51cab487488daa0c1b0a4605864de2775 WHIRLPOOL ddc5fcdcb04115b7c24ada6ebf8be9c374fbfd09bf368a9388110b9f8e509c2ae20ec78874767a52ffeed9ecf3ff3ee3c4bf59efcee304d274aa8154ad28cf72
diff --git a/dev-java/jansi/files/jansi-1.5-build.xml b/dev-java/jansi/files/jansi-1.5-build.xml
new file mode 100644
index 000000000000..c91033b9a2a5
--- /dev/null
+++ b/dev-java/jansi/files/jansi-1.5-build.xml
@@ -0,0 +1,251 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/4/13 7:11 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jansi-1.5" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jansi-1.5"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/fusesource/hawtjni/hawtjni-runtime/1.8/hawtjni-runtime-1.8.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-windows64.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-osx.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux32.jar"/>
+ <pathelement location="${maven.repo.local}/org/fusesource/jansi/jansi-native/1.5/jansi-native-1.5-linux64.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.7/junit-4.7.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ encoding="UTF-8"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/*Test.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/Test*.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/Abstract*.java"/>
+ <exclude name="**/Test*.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ encoding="UTF-8"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html">
+ <manifest>
+ </manifest>
+ </jar>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+</project>
diff --git a/dev-java/jansi/jansi-1.5.ebuild b/dev-java/jansi/jansi-1.5.ebuild
new file mode 100644
index 000000000000..844359ff128b
--- /dev/null
+++ b/dev-java/jansi/jansi-1.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="source test doc"
+
+inherit vcs-snapshot java-pkg-2 java-ant-2
+
+DESCRIPTION="Jansi is a small java library that allows you to use ANSI escape sequences in your console output"
+HOMEPAGE="http://jansi.fusesource.org/"
+SRC_URI="https://github.com/fusesource/${PN}/archive/${P}.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="dev-java/jansi-native:0"
+
+DEPEND="${CDEPEND}
+ test? (
+ dev-java/ant-junit4:0
+ dev-java/junit:4
+ )
+ >=virtual/jdk-1.6"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+S="${WORKDIR}/${PN}-${P}"
+
+EANT_GENTOO_CLASSPATH="jansi-native"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+EANT_TEST_GENTOO_CLASSPATH="ant-junit4,junit-4"
+
+src_test() {
+ EANT_EXTRA_ARGS="-Djunit.present=true"
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar "target/${P}.jar" "${PN}.jar"
+ use source && java-pkg_dosrc src/main/java/org
+ use doc && java-pkg_dojavadoc target/site/apidocs
+}