summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-28 05:14:38 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-28 06:26:24 -0500
commite6a7d2a7ebe140963f12c702fc12c4b3c5895150 (patch)
tree435d1fbf0aa9a8a6c88cae79225483d81affa0ac
parentapp-emulation/ruffle: add 0_p20220228 (diff)
downloadgentoo-e6a7d2a7.tar.gz
gentoo-e6a7d2a7.tar.bz2
gentoo-e6a7d2a7.zip
app-emulation/ruffle: sync live
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild30
1 files changed, 10 insertions, 20 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 58111094b040..5f575704c2b7 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2021-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,23 +12,17 @@ DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
EGIT_REPO_URI="https://github.com/ruffle-rs/ruffle.git"
-LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 ZLIB curl zlib-acknowledgement"
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 ZLIB curl"
SLOT="0"
-IUSE="gui"
-DEPEND="
+RDEPEND="
+ dev-libs/glib:2
dev-libs/openssl:=
media-libs/alsa-lib
sys-libs/zlib:=
+ x11-libs/gtk+:3
x11-libs/libxcb:="
-RDEPEND="
- ${DEPEND}
- gui? (
- || (
- gnome-extra/zenity
- kde-apps/kdialog
- )
- )"
+DEPEND="${RDEPEND}"
BDEPEND="
${PYTHON_DEPS}
virtual/pkgconfig
@@ -45,7 +39,7 @@ src_unpack() {
}
src_compile() {
- filter-flags '-flto*' # undefined references with tinyfiledialogs and more
+ filter-flags '-flto*' # undefined references with ring crate and more
cargo_src_compile --bins # note: configure --bins would skip tests
}
@@ -53,13 +47,9 @@ src_compile() {
src_install() {
dodoc README.md
- # does not have a real GUI yet, flag is used to ensure there is a
- # way for messages and file picker to be displayed with .desktop
- if use gui; then
- newicon web/packages/extension/assets/images/icon180.png ${PN}.png
- make_desktop_entry ${PN} ${PN^} ${PN} "AudioVideo;Player;Emulator;" \
- "MimeType=application/x-shockwave-flash;application/vnd.adobe.flash.movie;"
- fi
+ newicon web/packages/extension/assets/images/icon180.png ${PN}.png
+ make_desktop_entry ${PN} ${PN^} ${PN} "AudioVideo;Player;Emulator;" \
+ "MimeType=application/x-shockwave-flash;application/vnd.adobe.flash.movie;"
cd target/$(usex debug{,} release) || die