summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-01-01 14:00:48 +0100
committerFabian Groffen <grobian@gentoo.org>2021-01-01 14:01:32 +0100
commite6ace6b5dfc0a324ed2b848448acd3b1e2834847 (patch)
tree633e8846950b6ce0d24fb5a042e14ad503d60b7a
parentsys-libs/libcxx: wrap Darwin comments to line boundary (diff)
downloadgentoo-e6ace6b5.tar.gz
gentoo-e6ace6b5.tar.bz2
gentoo-e6ace6b5.zip
sys-libs/compiler-rt: add bootstrap workaround like for libcxx
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.1.9999.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.1_rc1.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.1_rc2.ebuild9
-rw-r--r--sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild9
5 files changed, 35 insertions, 10 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild
index e7c526429288..45cc6aa7b63f 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -46,7 +46,12 @@ pkg_pretend() {
}
pkg_setup() {
- llvm_pkg_setup
+ # Darwin Prefix builds do not have llvm installed yet, so rely on
+ # bootstrap-prefix to set the appropriate path vars to LLVM instead
+ # of using llvm_pkg_setup.
+ if [[ ${CHOST} != *-darwin* ]] || has_version dev-lang/llvm; then
+ llvm_pkg_setup
+ fi
python-any-r1_pkg_setup
}
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.1.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.1.9999.ebuild
index e93bdde90a88..07412646ab2a 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.1.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.1.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,7 +48,12 @@ pkg_pretend() {
}
pkg_setup() {
- llvm_pkg_setup
+ # Darwin Prefix builds do not have llvm installed yet, so rely on
+ # bootstrap-prefix to set the appropriate path vars to LLVM instead
+ # of using llvm_pkg_setup.
+ if [[ ${CHOST} != *-darwin* ]] || has_version dev-lang/llvm; then
+ llvm_pkg_setup
+ fi
python-any-r1_pkg_setup
}
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.1_rc1.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.1_rc1.ebuild
index e93bdde90a88..07412646ab2a 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.1_rc1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.1_rc1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,7 +48,12 @@ pkg_pretend() {
}
pkg_setup() {
- llvm_pkg_setup
+ # Darwin Prefix builds do not have llvm installed yet, so rely on
+ # bootstrap-prefix to set the appropriate path vars to LLVM instead
+ # of using llvm_pkg_setup.
+ if [[ ${CHOST} != *-darwin* ]] || has_version dev-lang/llvm; then
+ llvm_pkg_setup
+ fi
python-any-r1_pkg_setup
}
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.1_rc2.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.1_rc2.ebuild
index e93bdde90a88..07412646ab2a 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.1_rc2.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.1_rc2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,7 +48,12 @@ pkg_pretend() {
}
pkg_setup() {
- llvm_pkg_setup
+ # Darwin Prefix builds do not have llvm installed yet, so rely on
+ # bootstrap-prefix to set the appropriate path vars to LLVM instead
+ # of using llvm_pkg_setup.
+ if [[ ${CHOST} != *-darwin* ]] || has_version dev-lang/llvm; then
+ llvm_pkg_setup
+ fi
python-any-r1_pkg_setup
}
diff --git a/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
index e93bdde90a88..07412646ab2a 100644
--- a/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,7 +48,12 @@ pkg_pretend() {
}
pkg_setup() {
- llvm_pkg_setup
+ # Darwin Prefix builds do not have llvm installed yet, so rely on
+ # bootstrap-prefix to set the appropriate path vars to LLVM instead
+ # of using llvm_pkg_setup.
+ if [[ ${CHOST} != *-darwin* ]] || has_version dev-lang/llvm; then
+ llvm_pkg_setup
+ fi
python-any-r1_pkg_setup
}