summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-22 21:28:43 -0400
committerBenda Xu <heroxbd@gentoo.org>2020-11-09 15:54:02 +0800
commite6c6f26ab199eb11f4479d6870de262f9a9fb53d (patch)
treeacb97cc33bebe2214b38e6b5ae8f771cbad769d8
parentsys-kernel/git-sources: Automated version bump to 5.10_rc3. (diff)
downloadgentoo-e6c6f26ab199eb11f4479d6870de262f9a9fb53d.tar.gz
gentoo-e6c6f26ab199eb11f4479d6870de262f9a9fb53d.tar.bz2
gentoo-e6c6f26ab199eb11f4479d6870de262f9a9fb53d.zip
dev-python/plotly: version bump to 4.10.0
Closes: https://bugs.gentoo.org/641650 Closes: https://github.com/gentoo/gentoo/pull/17643 Reported-by: Martin H, Anton Bolshakov Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--dev-python/plotly/Manifest1
-rw-r--r--dev-python/plotly/metadata.xml4
-rw-r--r--dev-python/plotly/plotly-4.10.0.ebuild29
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/plotly/Manifest b/dev-python/plotly/Manifest
index 311b96dad542..3e25f85db560 100644
--- a/dev-python/plotly/Manifest
+++ b/dev-python/plotly/Manifest
@@ -1 +1,2 @@
DIST plotly-1.9.6.tar.gz 546722 BLAKE2B 5905af517ef40bc077492f01b49c367c0aa03a96accb86ec072e188a43e463c187a0b9dee3d0df33669aa6d600ed9127b067c7099947e5235331d14ce10bf33c SHA512 7564036ed3745fc06ee7428942e45ca6bfaefa1e47b08a5868a918924268ee632515f1de4bf3e90911234f18a4d85b092ecb6ef9f213b939093dcb433a12dec4
+DIST plotly-4.10.0.tar.gz 6263967 BLAKE2B a78ddf286993621a555cc7f34a5ad0f44e93dcceb9bdac2a20f0cd80257e90485f20b4c89a350a3718b104401d7677a762231c6a774e5c2757a2de1454822875 SHA512 bc32dac7e5621b254c3868e85ed18133ad8341bed5784f707a89242c5e1ef9959afc603a91ccb068aca24032d3ff5b44678811c405d579284334f051f59f93aa
diff --git a/dev-python/plotly/metadata.xml b/dev-python/plotly/metadata.xml
index b92ec11d7525..301f9875d592 100644
--- a/dev-python/plotly/metadata.xml
+++ b/dev-python/plotly/metadata.xml
@@ -5,6 +5,10 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
<longdescription lang="en">
Python plotting library for collaborative, interactive, publication-quality
graphs. Plotly is an online collaborative data analysis and graphing tool.
diff --git a/dev-python/plotly/plotly-4.10.0.ebuild b/dev-python/plotly/plotly-4.10.0.ebuild
new file mode 100644
index 000000000000..24a60e316802
--- /dev/null
+++ b/dev-python/plotly/plotly-4.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/retrying[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ mkdir -p "${ED}"/etc/ || die
+ mv "${ED}"/usr/etc/jupyter "${ED}"/etc/ || die
+ rmdir "${ED}"/usr/etc || die
+}