summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 17:24:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 18:48:13 +0100
commite6d756dd5f41b73191002d03dcf48dc24800593b (patch)
treeac553656f552aee9db31c04c257c13de14a5ebdb
parentdev-python/notebook: Bump to 7.1.1 (diff)
downloadgentoo-e6d756dd5f41b73191002d03dcf48dc24800593b.tar.gz
gentoo-e6d756dd5f41b73191002d03dcf48dc24800593b.tar.bz2
gentoo-e6d756dd5f41b73191002d03dcf48dc24800593b.zip
dev-python/urwid: Bump to 2.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urwid/Manifest1
-rw-r--r--dev-python/urwid/urwid-2.6.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index 1a52bb9284f2..0193e6175ea4 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -1,3 +1,4 @@
DIST urwid-2.4.6.tar.gz 801434 BLAKE2B 52b6cd256fbb6f7296619140c0d2cc9dacb910b3666dedb5e53f6c9c66eb17c628c2da7ec3e61ac7c24c9359161a032228bfa676ea9e53169ff3bef873782af3 SHA512 b7255b5f5f274fec952edb808ff859289dbd75f0600f3ddf1b608111f0fef50955efadeb1c1792fe16f5adc6c12a3641bfb50e42bbf8c07b10f431ca50cc0766
DIST urwid-2.5.3.tar.gz 848047 BLAKE2B 42815e22f2659ee25736767391afbf0189b5bec9d1100ce7631efd037989cfacac7ee921666e2400e1ef7ef114261a948cfac172ac993753ce151b370361d375 SHA512 80c32138347a618fc40e1a26fd174e708a9f8e4e9a8e09edc1d9261a9d73a644e356ce375654a55b5fb8838a820b8ba8b1cc47560c5b44c5c74677399845f578
DIST urwid-2.6.4.tar.gz 848823 BLAKE2B ad0f83f0b610d689b55dbc58464ea170be3ec7ed5f90f9c534b2707bd9fe867fdc06a690adf3357ecd9810f28ffb8126ac9d38068087b166641bcad695768b4e SHA512 659010d1f9f66a70d224a95381b477bd634cc2f90d79f117eba7e7dc7569373fd8c2f8de485e72df21b1434c307232e980a2019b018af662262ea2df4d70558c
+DIST urwid-2.6.5.tar.gz 851570 BLAKE2B c99833701b83427005726d9a0d5e1c52f2308617bd7a953370495b0a35fd904c2544a186dd9f74d571045d4dc74af285f9a1da0e3357fdd85ed5ae0162aca3ba SHA512 813b4cfc3f4d418475fdd23b84bf591a6affc30522b18e9f58c067bd71f3bc98962f50866a4b34974d66287a7e5600fdfdf9955fea6cb94c08c1c11a4515e5a8
diff --git a/dev-python/urwid/urwid-2.6.5.ebuild b/dev-python/urwid/urwid-2.6.5.ebuild
new file mode 100644
index 000000000000..0d52239b0d14
--- /dev/null
+++ b/dev-python/urwid/urwid-2.6.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Curses-based user interface library for Python"
+HOMEPAGE="
+ https://urwid.org/
+ https://pypi.org/project/urwid/
+ https://github.com/urwid/urwid/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf urwid || die
+ eunittest
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Trio event loop" "dev-python/trio"
+}